Ford Powerstroke Diesel Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi everybody,

new member, long time reader. I am having some issues with my 2003 6.0. last week i got the truck back after having the oil cooler, ipr, icp, injector harness, and cylinder 1 injector and cylinder 5 injector replaced. All parts from the ford dealership. The truck ran great when i got it back! Last night i took the wife and kids for a long cruise to get dinner for the kids birthday, while coming up a long hill I hammered it and it pulled great and didn't skip a beat. about 2 miles later i stopped for fuel and when i started back up the truck was smoking gray/blueish while accelerating. seems to run fine, builds boost fine. but DUMPS grayish blue smoke. not losing coolant, atleast not that i have noticed, doesnt seem to be loosing oil like crazy. i got the truck home and pulled several codes:

P0261
P0275
P0671

ficm voltage is good all around, cannot find any busted up wires, no oil in the downpipe, no blowby, all stock minus the egr cooler has been deleted.

Any advice on where to look next?
 

·
Premium Member
Joined
·
3,109 Posts
What does the smoke smell like? Sounds like an injector overfueling. If you had just done the work, I'd help you troubleshoot. But, if it were me, I'd be taking it back to the dealer for them to fix. Might wanna tow it there though, if it's dumping that much smoke.

-jokester
 

·
Registered
2004 Ford Excursion Eddie Bauer
Joined
·
5 Posts
Whats your fuel pressure at? Is your fuel pump making any squealing sounds? Might wanna get those glow plugs replaced or your glow plug module checked out.
I had low injector circuit codes pop up and were due to my fuel pump being weak and on its way out it did make squealing sounds while priming KOEO.
I replaced pump and codes never came back and truck is running strong.
But as far as the smoke I think your cylinders aren't burning efficiently because they are too cold, without glow plugs which do cycle on and off throughout operation.
 

·
Compression Ignition Addict
Joined
·
8,248 Posts
Whats your fuel pressure at? Is your fuel pump making any squealing sounds? Might wanna get those glow plugs replaced or your glow plug module checked out.
I had low injector circuit codes pop up and were due to my fuel pump being weak and on its way out it did make squealing sounds while priming KOEO.
I replaced pump and codes never came back and truck is running strong.
But as far as the smoke I think your cylinders aren't burning efficiently because they are too cold, without glow plugs which do cycle on and off throughout operation.
FYI - Glow plugs don't come on after the oil temp is above 130*F
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
What does the smoke smell like? Sounds like an injector overfueling. If you had just done the work, I'd help you troubleshoot. But, if it were me, I'd be taking it back to the dealer for them to fix. Might wanna tow it there though, if it's dumping that much smoke.

-jokester
Smells more like oil than anything. I'll definitely be taking it back, the mechanic is a friend and will make it right, however he is super busy and I have the relative knowledge to work on these trucks so I am trying to track it down since its here in the driveway while I wait for him to get some free time. Should I be looking at the other 6 injectors since 2 were just replaced? I've been worried about the turbo but did not find oil in the downpipe
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
Whats your fuel pressure at? Is your fuel pump making any squealing sounds? Might wanna get those glow plugs replaced or your glow plug module checked out.
I had low injector circuit codes pop up and were due to my fuel pump being weak and on its way out it did make squealing sounds while priming KOEO.
I replaced pump and codes never came back and truck is running strong.
But as far as the smoke I think your cylinders aren't burning efficiently because they are too cold, without glow plugs which do cycle on and off throughout operation.
Fuel pump sounds good, as far as the glow plug goes, one of the clips wasn't clipped in all the way. Fixed now, but still dumps blue smokes when I give it throttle. I did notice that a tiny bit of throttle won't smoke, but taking off from a stop and getting up to speed it smokes pretty good. I was assuming turbo because more boost=more smoke but found no oil in down pipe
 

·
Registered
2004 Ford Excursion Eddie Bauer
Joined
·
5 Posts
Very well could be seals if turbo is old a rebuild might not be a bad idea i just rebuilt mine for $80 and doesn't take anything special to do it. I'm experienced but anyone can do the job with watching videos from diesel tech ron.
 
1 - 8 of 8 Posts
Top