Ford Powerstroke Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1
My dads 01 SD (in sig) has been starting really slowly lately. We know that the starter was just about shot but the Interstate batteries are only 2 years old.
This mornin he went to start it up and it would click but wouldn't crank so we put the charger on it just incase the batteries might have been a little weak. The drivers side had a really good charge but the passenger side was a slight bit weak but not enough to matter.
The problem was that when I switched the charger clamps from the pass side battery to the drivers side, I didn't think anything about it and just put them on in the same order they were on the other side...backwards + to- and - to +. :doh: I didn't realize it until a minute later :doh: I looked and the charger showed it wasn't charging so i immediatly unplugged it.
Now when you turn the key to light the glow plugs, all the dash lights come on and sort of "pulse" while the tach and spedo move up back and from under the dash there is some weird vibrating/buzzing sounds and when you hit the strarter, it just clicks like a dead battery although they arent.:dunno::dunno:
Right after he got the truck the seal along the bottom of the windshield leaked a little water down and shorted out the PCM each time he washed it. Now it's acting the same way it did then.
I unhooked the battery cables in hopes that it might reset itself so that it might start tomorow so we can get it to the dealer.:dunno:
 

·
Registered
Joined
·
283 Posts
Discussion Starter #2
dad talked to the dealer today and they said that it's most likely a bad battery...
when you hookup the passenger side batt, the hood light comes on dimly but when you hook up the drivers side it comes on bright. I'm gonna go pick up a set of new battery's for it and hope it works:dunno:
 

·
Registered
Joined
·
283 Posts
Discussion Starter #3
A pair of new batteries and she's runnin like a champ:woot:
 
1 - 3 of 3 Posts
Top