Ford Powerstroke Diesel Forum banner

temperature

  1. 99-03 7.3L Powerstroke Problems
    I recently noticed my coolant temperature was over 500 degrees Fahrenheit when I had just started the engine. Great! I replaced the ECT sensor. It's located just to the left of the thermostat housing. I attached a photo to be crystal clear of what I replaced. Now my temperature is reading...
  2. 6.0L Problems Forum
    I just got my '06 6.0 in January. Drove it all spring with no problem, and from Dallas to California with no problems. However, in the past two months the temp. has been going bat-s**t crazy and I have NO idea whats up. What's on the truck: Sinister coolant filter installed (with clean filter)...
  3. General 6.0L Discussion
    Hi Everyone, New here. I have a 2005 F250, 299k miles, previous owner did the following: EGR deleted, head studs, there is no CEL and EGT valve always reads 0% for command and status so there may be some sort of tune in it. The truck drives like it is stock from what I can tell. I don't tow...
  4. 99-03 7.3L Performance Parts
    Thanks to CSIPSD, I got my isspro gauges in today. I was wondering, what do you guys think I should set my Egt and trans temp warning lights at? Thanks!
  5. 6.0L Problems Forum
    I am a new owner of a diesel truck. I purchased a Ford F-350 6L in August with 88,500 miles and now have 101,500 miles. I park my truck outside and use a block heater that is plugged in whenever I am not driving (when temperatures are 32 F or below). I live in the Chicago area and the...
  6. 6.0 Trannie problems
    I've been having the tow/haul light flash a few times when starting the truck recently. It would flash until the tranny temp finally came above the cold, then everything would drive smoothly. Until the temp was normal the shifts were very hard and seemed to be in 'limp' mode. Yesterday the...
  7. 99-03 7.3L General Discussion
    Ok, I've been rebuilding my motor and I've been looking into everything and I need some help. From what I think; witch is probably wrong :tard:; there are two intake air temp sensors. 1st is located in the intake right by the air filter box and the 2nd is located in the intake manifold / turbo...
  8. 6.0 Motor problems
    Good Evening, Quick question for you all... 190K miles no studs running "Looney Tune" 99% highway driving, rarely (anymore) do i WOT run it within 6months- new oil cooler, egr delete, new powermax and ICP, IPR, EBP(X2), MAP sensor, new pigtails injectors 4,6 and 7 replaced I am an idiot...
  9. 6.0 Motor problems
    So here's the deal. Did an EGR delete. Installed a sinister diesel coolant filter kit. Did 2 restore plus and 2 restore cleansing cycles, with about 3 distilled water flush cycles. Replaced my thermostat just in case. Haven't replaced my clogged oil cooler yet (25 degree EOT/ECT difference)...
  10. 6.4L Problems Forum
    So I'm driving to Colorado. Goin thro Dallas which was first traffic congestion. I've been running my tuner on hot damn hot. Best mpg's and power of course. Well temps read about 198- 204 on oil and coolant somewhere close to that all day. Get to Dallas and slow down from 80 to 40 and the temps...
  11. 6.0 Motor problems
    Hello fellow Powerstroke enthusiasts! I'm fairly new to the forum but not new to the Powerstroke scene. I apologize in advance for the long post but I would like to include as much information as possible. I have a 2003 6.0 with close to 180,000 on the odometer. I've owned it since 2006 and when...
Top