Ford Powerstroke Diesel Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 209 Results
  1. 94-98 7.3L Problem Forum
    I was driving my 1995 7.3, 2wd, dually to work when it died. I sat for about 10 minutes and was able ro get it running (although poorly) and limped it to work where it died again. Engine cranks but doesn't start. No smoke from exhaust. Tachometer moves when cranking. According to My EDGE CTS 3...
  2. 6.7 Problems Forum (2011-2016)
    2011 6.7 4x4 - truck ran fine. My fuel return line was leaking so I replaced it. While I was already working on my truck I decided to install an A.R.E. disaster kit. Also my pcv was giving codes so I replaced the driver side fuel rail w/new sensors already installed. I have purged multiple times...
  3. 6.7 Problems Forum (2011-2016)
    Recently on my 2013 6.7 decided to install a non vgt turbo and fuel filter bypass after the kits were installed vehicle started and ran for about 10 seconds then killed it through pcm codes and began to click as if the battery’s were dead. Charged them snd same results drained the oil to find a...
  4. 6.4L Problems Forum
    2008, 250, 6.4L Lariat, short-bed, 4x4, crew cab Went to grab lunch and then came back home and parked. The next day, I come out and tried to start the truck but it just made a loud whirring sound. I tried again and same thing happened. The whirring sounds like the starter motor is attemping...
  5. 6.7 Problems Forum (2017-2019)
    i have a 2019 f-350 platinum with a 6.7l. a couple weeks ago it would randomly shut off going down the road with no warning. if you tapped the fuse box, it would start right up. i’ve replaced nearly every fuse, the batteries. we’ve tested every wire etc. after it shut off 7-10 times on the way...
  6. 6.0L Problems Forum
    For about 3 weeks now, I have been unable to start my truck after doing standpipes, dummy plugs, oil cooler, stc fitting, and injectors(A lot of time waiting on testing tools). Testing through the IPR, there is evidently a large HPO leak as you can hear a large air leak on the driver side and...
  7. 6.0L Problems Forum
    I just replaced the injectors, stc fitting, standpipes, dummy plugs, and oil cooler on my truck. I have tried probably 20 times to crank the engine over by jumping the starter solenoid to prime the oil system. There's no codes, the fuel filter and oil filter housings are filling, there's good...
  8. 6.0L Problems Forum
    We just bought this truck has 188000 miles. Started and drove great no issues. Towed our little 19 foot camper home great. A week later just started bucking felt like the driveshaft was losing a u joint under load but went away when I lifted my foot. A couple minutes later it lost power then...
  9. Diesel Diagnostics
    Hello there! I have a 2005 F350 6.0, just did the head gaskets (again) now that everything is back together I am have a no start condition, this is where is gets weird, I have plenty of oil pressure around 1500 psi I have ficm sync. Ficm voltage is 48-48.5, rpm while cranking is around 150, I...
  10. 94-98 7.3 Motor Problems
    Little back story. Have low compression. Listened to a buddy and bought some restore oil additive which has metal flakes that supposedly fill the holes in the cylinder and give you better compression. It died a half mile later. Got it towed home and emptied HPOP and cleaned and rebuilt IPR...
  11. 6.0 Motor problems
    Hey guys, new to the forum and have a question. I recently picked up a 2006 f350 with the 6.0L Powerstroke in it as a summer project, and I'm getting a crank, no start condition (cold). This is my first 6.0 so help is much appreciated! Truck/Conditions info: 2006 f350 6.0 factory head bolts...
  12. 6.0L Problems Forum
    Okay so, long time lurker, relatively new poster. this is my 6th 6.0, I know, I hear it enough from my friends. 2005 F250 Studs EGR delete BPD HD Air oil cooler 190/30 Warren KC 64.7 DIY Regulated return fuel bowl delete 6.7 fuel pump 66 PSI at all times ALL motorcraft filters ALL the time...
  13. 6.0L Problems Forum
    What's up guys? I drive the 03 6.0 and I've run into a dead end with a no start situation, so I'm hoping if I post exactly what's happened someone much smarter than me may be able to help. Here we go. Truck started and ran great drove about 100 miles with stops in between, get back to town and...
  14. 6.0 Motor problems
    HPOP went out. Replaced pump, and ipr valve. unit will not start. does not build past ~200psi icp. at cranking the values are as follows: ficm sync: yes main: 48, 11,11( they will drop down to 9.5 after cranking for a bit) batteries have been trickle charged over night and load tested, both...
  15. E-Series Van Discussion
    Hello. I could use some help. I believe a got bad fuel and it gelled. 2006 E350 6.0L usually starts easily. One cold morning had a tough time starting, took 4 tries to get started. Was running late so I didn’t allow adequate time to warm to operating temp. Van seemed to be running fine but...
  16. 6.0 Repair Help
    I just replaced the OEM oil cooler with the BPD oil cooler kit. I did not fill the valley back up to prime the HPOP. When I crank the engine ti start I read good FICM Sync, good IPR, good ICP voltage, hpop pressure started less then 500psi now its getting to 500-1000+. My question is should I...
  17. Powerstroke.org Builds & Projects
    Hey all, 2001 f250 super duty 7.3 4x4, 82K, just finished up with a motor swap from an 01 to a 99. Not a 99.5 I had to Franken build the 99 from the 01. The 01 had bad cylender walls and needed replacing and 300K miles on it... but the rest of the motor was good. The 99 had a good block and...
  18. 6.0L Problems Forum
    so i did my hpop and stc fitting a few days ago and my truck was running and starting fine. till today i started it went to the gas station turned it off and it started good then i get to my job site and when i got to leave i try to start my truck and it just cranks, any ideas what it could be?
  19. 6.0L Problems Forum
    Problem has occurred for about the pass 2 months. Currently had my starter and all my battery connections replaced(By shop) along with injectors(My self) within this time period. I've read multiple forms on this topic and seems majority found either starter or bad ground. My case is neither...
  20. 6.4L Problems Forum
    Ok, pretty sure my dpf was getting clogged. Usually remove after yearly smog and run dpf delete tune. I recently got a motorcycle so very limited driving, thought I would leave it in until after smog next year. So, I clear the egt temp errors right away and thought it should start. No joy...
1-20 of 209 Results
Top