Ford Powerstroke Diesel Forum banner

lpop

  1. 6.0 Motor problems
    Howdy! I'm new to the Power Stroke forum and a new owner of a 2004 F-250 with the 6.0 diesel engine. This is the first diesel I have ever owned, but I've been reading a lot of posts on this forum and have familiarized myself with this engine enough that I'm ready to ask what I believe will be...
  2. 99-03 7.3 Motor Problems
    Hello everyone. I have been scratching my head lately over an issue and am afraid that I might need to pull the engine and re-seal my LPOP pickup tube. However I really don't have the time and resources to do that right now so I thought I would bring the problem to you first and see if anyone...
  3. 99-03 7.3 Motor Problems
    Hello all, I have an 01 7.3 with 263K miles on it with original injectors, HPOP, LPOP. Valve covers have never been off. Original turbo, original alternator. I was just curious if anyone else has seen the same life out of injectors, HPOP. Is this the exception or no? I do run a 2 filter...
  4. 6.0 Motor problems
    (SOLVED) Replaced LPOP gears now NO OIL to the oil filter canister. (SOLVED: read below) Before: Crank No Start. No reading on the dash oil gauge. So with oil filter removed and oil filer drain plunger closed it would crank for 17 sec before oil would enter the canister. Took 10 additional...
  5. 6.0 Motor problems
    Okay, it's been a while I have just recently returned from a Deployment to Afghanistan and had to leave my '06 F350 not running because i ran out of time. It was running and then stopped running one day back in January. I have changed every sensor ICP/EBP etc HPOP, branch tube (had to take the...
  6. 99-03 7.3 Motor Problems
    Melted a piston and had to completely rebuild my '01 7.3l. All new Ford OEM parts, including the LPOP. I can fill the HPOP reservoir, start the truck, but it will not build any oil pressure on the engine oil lubricant side. The pump is getting prime, filling the oil filter, but not showing up...
  7. 6.0L Problems Forum
    Not getting any oil pressure while cranking, and the oil filter housing does not fill with oil while cranking and having someone push down on the valve. What is the best way to determine if it is a bad oil pump or a bad pickup tube? Is there something else i could be missing?
  8. 99-03 7.3 Motor Problems
    Ok guys, looking for some fresh Ideas. I Still have an oil leak. :doh: The Valley is DRY. It's not coming from the back of the engine. It's coming from the front, in the oil cooler / LPOP area. I don't think the LPOP is bad as I have NO starting issues and the pressure is good, and it does not...
Top