Ford Powerstroke Diesel Forum banner

loss of power

  1. 99-03 7.3 Motor Problems
    Ive been reading on the forms here for a few years but haven't posted much but now i really need a little help. I have a 2000 7.3 F250. The only mods so far are an exhaust and edge evolution. If im driving normal i can see boost psi of up to 14. If i push on the go pedal any past that the boost...
  2. 99-03 7.3L Powerstroke Problems
    first post! so i've lurked around here for awhile reading and learning. this site is awesome to say the least! so here's my issue. i've got a 2000 drw cab and chassis truck with the 40 gallon aft axle metal tank. i've had some problems recently with lack of power, low fuel pressure. pulled the...
  3. 99-03 7.3L Powerstroke Problems
    Ok whenever I drive my truck in the cold between 25 and 40 mph as I start to give it throttle its acts as if whatever boost would be going to my motor is going thru a blow off valve. Sounds a little like whrn you put your hand over the intake on a lawn mower. Combined with no power. If I let off...
  4. 94-98 7.3 Motor Problems
    I have a 1996 7.3 F250. Its all stock aside from a TS chip, and a stack. When I start it in the morning, with the block heater plugged in overnight...I get a sucking sound coming from my stack. I lose power, and it doesn't stop unless i get on it...or it gets up to temp. I dont know what it is...
  5. 6.0 Motor problems
    I was having problems with after down shifting back down to around 2000 rpms it has a hard time getting past it and will black smoke a lot so i pulled the egr a cleaned it i did have to replace one of the O-rings and had to re-tap one of the holes that the bolt goes in the code for the EGR is...
  6. 6.7 Motor Problems (2011-2016)
    I've had my 2011 6.7 for 14k. Every time I load it with 9k lbs it seems to pull fine until I reach any kind of incline at higher speeds. The turbo boost falls from 20psi to 10psi and in some cases I can't even maintain the speed limit. Unmodified 7.3s pass me on hills and a dodge v10 can stick...
  7. 6.0 Motor problems
    I had an issue with my 04 losing coolant (03 motor)... I broke down and installed an EGR delete about 10 days ago. She was back in her full glory. The new issue started yesterday. I had to go to a buddies house. She ran fine the 2 mile trip there and I never got above 45ish. When I started the...
  8. 6.0 Motor problems
    I have a 2005 f250 6.0 with a six inch lift kit, it has about 107,000 miles. I took a long trip from south illinois up to chicago. After the coming back the next day my truck started to black smoke and was not getting power as quickly. Now it no longer black smokes and is blowing white smoke. I...
  9. 94-98 7.3 Drivetrain Problems
    Last weekend I replaced my stock downpipe with a 3" from Diamond Eye & cat delete pipe as well. I had the tranny out to replace the dual mass flywheel with a single mass, so I thought it would be a good time to do it. I have the DIY air filter on order but have not installed it yet. It used...
Top