Ford Powerstroke Diesel Forum banner

knock

  1. Front end Knock 2009 f350

    Suspension & Steering
    I have a 2009 F-350 that I recently replaced the entire front end on. And I was having trouble with my steering damper bracket moving when I turn where it's mounted to the tie rod, and causing a squeak. I had a new bracket made to stabilize the dampers, but it did not get rid of the squeak. Now...
  2. Hutch Mod - Knock Tapping

    99-03 7.3 Motor Problems
    For those of you who have been helping me with advice or following my thread orig posted at: http://www.powerstroke.org/forum/99-03-7-3-motor-problems/508858-knock.html Any way I went ahead & done the Hutch Mod using: 1 - 3/8" tube compression union 1 - 5/16" tube compression union 3ft - 5/16"...
  3. Bad Injector?

    94-98 7.3 Motor Problems
    Ever since ive owned my 1997 f350 with a 7.3L its had a knock in the engine. Ive been trying to figure out what it was, theres no real loss of power but i get terrible fuel economy. Im pritty sure its a injector now from the reasearch ive done. but im not sure which injector it is or how to...
  4. Hard knock or thud when warm

    6.0 Motor problems
    Hello, I have a 03 F350 6.0 with 136k. I recently changed my air filter, oil filter, oil, fuel filter, and thermostat. Now when it gets to about 140-150 ect, it hits really hard. It has been pretty cold and does have problems with cold starts but I never had this issue until I changed all these...
  5. Single cylinder knock?

    94-98 7.3 Motor Problems
    Hi, all - Frequent lurker, first time poster.* I'm not a mechanic by trade, but I do a fair bit of car/truck repair and have worked on diesels in the past.* That said, I've never had to troubleshoot something like this and I haven't found any posts that seem to relate this sort of issue. * First...
  6. Knock/Tick after new Oil cooler

    6.0L Problems Forum
    I recently performed coolant flush, replaced with ELC, had Oil cooler rebuilt and installed coolant filter. My delta temps were 10-15 degrees so I decided to go ahead and do it before I had a problem. After the rebuild the clamp was loose at the turbo causing low power. Clamp was tightened...
Top