Ford Powerstroke Diesel Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 84 Results
  1. 99-03 7.3 Motor Problems
    This all started with a p1280 code on my 2001 for excursion. Being cheap I went to Napa and purchased and new ICP sensor. That did not fix the issue, so I assumed it was the Pigtail. I replaced the ICP pigtail, still did not fix the P1280 code. I started checking the wires with a multimeter and...
  2. 94-98 7.3L General Powerstroke Discussion
    Hi, I have a 1995 7.3 f250 with a no start condition. Truck has 200k miles on it and runs very well and strong. This happened about a week ago and the truck started to hick-up and die getting home but would start and run for a minute or so after long cranks. This truck has the 1995 OBD2 1.5...
  3. 99-03 7.3L Powerstroke Problems
    Okay guys, new to this site, first forum ever. I have a 2000 f250 7.3L auto trans. “mods” done are Full billet 4r100 Billet triple disc torque converter Bellowed up pips Ebpv delete Deleted pedestal Wicked wheel Hydra tuner Custom tunes. The issue is it will idle fine, a surge every...
  4. 6.0L Problems Forum
    I bought an early 04 6.0 a while back, it was running great and all of the sudden my oil pressure dropped to zero at idle. It also started to have a long crank and took about 7-8 seconds to start whereas it used to only take 1 or 2. Obviously it still had oil pressure or else it would not be...
  5. 99-03 7.3L General Discussion
    Very rarely my truck will just shut off while i’m coasting to a stop, when it shuts off the low oil pressure light comes on and all electrical stays on and working fine. after it shuts off i put it in park and start it back up like nothing happened. i just recently replaced the icp and pigtail...
  6. 94-98 7.3 Motor Problems
    1997 7.3 F250 with a crank no start. Truck sat for about a year. New ICP, IPR, and CPS Currently no codes when I try to read them with FORscan, but batteries were replaced so maybe that is why. I plugged in FORscan and watched the ICP, IPR, and CPS signals live (see photo) I get flat lines for...
  7. 99-03 7.3L General Discussion
    So I have a 1999.5 7.3l powerstroke I’ve changed my icp, my ipr, and my cam sensor was running good after I changed my icp was driving it all around town until I cut it off at the last store on my way home it wouldn’t crank so I changed the cam sensor started up got me home cut it off then tried...
  8. 6.0L Problems Forum
    Hello community. So this one has me stumped, maybe one of you could shed some insight. But first, “The Story” So, I have a 04.5 6.0 CC. I bought the truck from the original owner for dirt cheap because he suspected it needed head gaskets. Truck looked very clean in the photos I received, so I...
  9. 6.0 Motor problems
    Nearly there - new injectors, glowplugs and was ready to replace STC fitting but someone had been there before. Must had dumped a few crumbs under the HPOP oil cover and had a blocked IPR screen - replaced that (diagnosed with autoenginuity) maybe need to go in and do another screen replace...
  10. 6.0L Problems Forum
    Okay so, long time lurker, relatively new poster. this is my 6th 6.0, I know, I hear it enough from my friends. 2005 F250 Studs EGR delete BPD HD Air oil cooler 190/30 Warren KC 64.7 DIY Regulated return fuel bowl delete 6.7 fuel pump 66 PSI at all times ALL motorcraft filters ALL the time...
  11. 6.0 Motor problems
    HPOP went out. Replaced pump, and ipr valve. unit will not start. does not build past ~200psi icp. at cranking the values are as follows: ficm sync: yes main: 48, 11,11( they will drop down to 9.5 after cranking for a bit) batteries have been trickle charged over night and load tested, both...
  12. 6.0L Problems Forum
    Hello everyone. I have a 2004 6.0. 153k miles A few months ago it was bulletproofed with new oil cooler, water pump, head gaskets (machined and o-ring), seals and o-rings from the block up. 2 days ago in Woodland Park, CO, I went into the store and came back out and there was oil EVERYWHERE...
  13. General 6.0L Discussion
    I need input on an issue with my 2004 6.0L. It is making an odd revving sound when returning to idle. This issue us accompanied by a surging/loss of power. the IPR during these times is in the mid-30% range while the ICP is around 600-800psi. I do not notice any smoke when this is happening...
  14. General 6.0L Discussion
    Hello, My name is Walter, I recently bought a 2006 Ford F-250 Diesel with a 6.0 engine. First, I brought the truck in to a shop for an oil change and to have the check engine light diagnosed. In the process of diagnosing, the truck stopped running. It would not start because there was not...
  15. 99-03 7.3 Motor Problems
    Hi All! Been reading great stuff on this site for years. First time i speak up! Stranded after driving my 99 7.3 8 hours. I ran low on fuel pressure all of a sudden. Got towed to a Hotel. I have Wife and 3 kids with me and it's around 0 to 15 during the day. i Replaced the IPR to get pressure...
  16. 94-98 7.3L Problem Forum
    Experienced Diagnoticians, My 97 7.3 with 225k miles has started to idle roughly and run roughly until fully warmed up and, then sometimes even after its warmed up. No surprise, its winter time. It is particularly noticable when engine is still cold and going up a hill. Sometimes it will even...
  17. 6.0L Problems Forum
    Right to the point then I'll paint the picture. 2007 F250 No injector clatter BUT does start then runs really really rough KOEO all sensors perfect except icp, voltage is .33 check, and icp is 90psi?? Once it starts icp shoots to 3400 and ipr to 55ish runs like crap can't find idle eventually...
  18. 99-03 7.3L Powerstroke Problems
    I've got an '03 7.3 with ~230k miles. I had oil leaking out of the HPOP so last week I finally got around to resealing it as well as the fuel bowl. changed the oil, put it all back together, started up fine. Drives fine. But I get the CEL to kick on any time i'm pushing it and im accelerating...
  19. 6.0L Problems Forum
    So Ive got a 2003 6.0 PSD. It wouldn't crank but unplugging the fan clutch solved that, now it will just crank. The ICP has oil everywhere so i unplugged it. I plan to change it out soon. That didn't change anything. Good fuses, good ficm, good starter and solenoid. Im out of options I could...
  20. General 6.0L Discussion
    been searching the threads; can't find an answer. 2007 F250 6.0L with 138k on the ODO. was starting to take longer and longer to kickover, so I benched it and began working on the engine. Found one of the dummy plugs to have an O-ring that was starting to fail. Figured while I was in there...
1-20 of 84 Results
Top