Ford Powerstroke Diesel Forum banner

injector issue

  1. 6.0L Problems Forum
    Changed my oil this weekend and within 100 miles of driving my check engine light came on. Thought maybe it had to do with the oil change, but when I checked the codes (P0261, P0264, P0267, P0270, P0273, P0276, P0279, P0282) it was a low circuit on all 8 cylinders. The truck is running EXACTLY...
  2. 6.0L Problems Forum
    Hello, I'm new in this forum... I leave in Brazil... so apologize me the bad english! I use a Powerstroke 6.0 in my RV E450 2009. I needed to replace a injector because one coil is damaged in short circuit. After the replacement the engine runs ok for about 10 miles and the coil of the new...
  3. 6.0 Motor problems
    Hey all, This is my first post but I've been browsing the forum since my purchase of my late 04. I got the truck from a good friend of mine about a year ago and it ran perfect at the time of purchase and the whole time he has owned the truck (I know because I have spent a lot of time with the...
  4. Testing Forum
    Hello Everyone! Yesterday I replaced the fuel filter on 1993 F350 7.3 non-turbo. Today, I was going about 65mph when i heard a loud knock develop in the motor. The truck now idles very rough too. Considering I went to town to top off the fuel, could that be a factor? In reading on here, I...
  5. 6.0L Problems Forum
    I started my truck cold morning, started really rough, once warmed up was sounding like maybe a injector was no working, but as i kept driving, bout an hour later or 2, truck started idling really weird and no power, it jus would not want to move, i can depress pedal all the way down and would...
  6. 6.0 Motor problems
    One of my customers installed a reman engine. Everything was great but within a couple weeks, he had a rough runner. The shop (Ford Dealership) determined that combustion somehow got past the brass washer and burned the o-ring on the injector. A new injector was put in and a couple weeks...
  7. 94-98 7.3L General Powerstroke Discussion
    I replaced an injector yesterday and I noticed that one of the injector wires was crushed under the valve cover. it appears that some of the wires are exposed, but it looks like the injector is still working. When I disconnect the wire while the truck is running the truck almost dies. Is it...
  8. 94-98 7.3L Problem Forum
    So I have a 95 F-250 with 320500 mi. After letting off of the throttle and getting back onto it white smoke dumps from the exhaust for around 500ft. (also does this when taking off). It has progressively gotten worse over the past week since it's gotten colder. I have also noticed it takes it...
  9. 6.0 Motor problems
    Here we go... Working on my buddy's 04 6.0 helpIng him install a new turbo and # 8 injector. Teardown was a breeze. So was install. But after everything is done she won't fire. ICP will not go over 167 psi unless I unplug icp sensor on right front of valve cover then it will get up too 800+...
  10. Engine 911
    I know this is similar to others so hopefully a new thread is ok. I'm looking at buying an 05 with the 6.0. It is selling cheap due to it having issues. It smokes on startup but quits when it is warm. The guy tells me he has deleted the egr. Here is the strange part to me. He says he...
Top