Ford Powerstroke Diesel Forum banner

hvac

  1. 6.4 Electronics Discussion
    Hi All! I'm new here. For my first post I've got a mystery involving a non-working climate control system in which all the relays and fuses test good, the blower motor works, the speed selection dial works (therefore the resistor also works), and yet I have no climate control whatsoever. So...
  2. 6.7 Problems Forum (2011-2016)
    Hey All, On my way to work this morning i came across an odd dilemma with my defrost. I went pass a car and when i got on the throttle i noticed a noise similar to a rock getting kicked up into the fender which is what i thought it was so i didn't pay any attention to it. a few minutes later i...
  3. 6.4 Motor Problems
    So I recently just bought this 2009 6.4, only 140k. She is a beauty. It has the H&S minimaxx on it but only have it set on stock since i have the DPF deleted. I watch my temps and what not regularly. Anyways I went out the other morn to warm her up about 4:45 am. Outside temp was about...
  4. 6.0L Electronics Discussion
    Hey all, lurking for years, seldom post, but gained TONS of knowledge, so thanks to you all! 2005 QC 250 Lariat, 218K miles strong. 100 degrees today, and the AC starts blowing out the defrost. Not my first rodeo with vac leaks, so I swap the pump, no change, I swap the solenoid, no change, I...
  5. 6.7 Problems Forum (2011-2016)
    Started up the truck with the the key and the heater/ AC unit was turned off (windows down) since it was a nice day (80) in sunny California. While driving i noticed it was getting pretty warm inside the cab for the day. Rolled up the windows and it got real warm, started to feel around and...
  6. 6.0L Electronics Discussion
    So my issue seems to be pretty common. The HVAC system works fine with temperature and fan strength, but it only blows out of the defrost vents. I have read several threads on this topic, and checked out the vacuum system. It all appears to be fine. I can hear the pump turning on when I crank it...
  7. 6.0L Problems Forum
    Replace the blower motor and the blower motor resistor. No change, still weak air coming out of the vents. Switch still has all four speeds but the highest speed on max a/c is still only 70% of what it used to be. Any suggestions?
Top