Ford Powerstroke Diesel Forum banner
hpop
1-20 of 152 Results
Advanced
  1. 6.0 Motor problems
    Looking for some help with standpipes. I’m on my 3rd set in 12 months I keep blowing the o rings. I’ve replaced with AVP updated one but they keep failing, just curious about what could be causing this and if I should just get the motorcraft ones. I keep using the avp because they warranted them...
  2. General 6.0L Discussion
    On the 6.0 HPOP update kit, the updated STC fitting has 3 holes(2 bolt holes). Why does the updated fitting have 3 while the old one has 2(just for the bolts). I’m trying to track down a high pressure oil leak and noticed while sending air through the system that all the air is coming out of it.
  3. 6.0L Problems Forum
    I just replaced the injectors, stc fitting, standpipes, dummy plugs, and oil cooler on my truck. I have tried probably 20 times to crank the engine over by jumping the starter solenoid to prime the oil system. There's no codes, the fuel filter and oil filter housings are filling, there's good...
  4. 6.0 Motor problems
    Nearly there - new injectors, glowplugs and was ready to replace STC fitting but someone had been there before. Must had dumped a few crumbs under the HPOP oil cover and had a blocked IPR screen - replaced that (diagnosed with autoenginuity) maybe need to go in and do another screen replace...
  5. 99-03 7.3L General Discussion
    Hey guys, 1999 f250 7.3 zf6. Thing starts when cold pretty well but as soon as it warms up has slow throttle response and doesn’t restart. Checking the icp it it’s only making 350-400 when hot. Replaced IPR and ICP, charged high pressure system with shop air and there’s no apparent leak. Double...
  6. 6.0 Motor problems
    Greetings folks. I have read many forums over the years and usually can get things fixed by the wisdom shared. I haven't found anything like this anywhere and now need an answer that hopefully someone can provide. Just replaced my head gaskets... put it all back together and had it idle for...
  7. 6.0 Repair Help
    I just replaced the OEM oil cooler with the BPD oil cooler kit. I did not fill the valley back up to prime the HPOP. When I crank the engine ti start I read good FICM Sync, good IPR, good ICP voltage, hpop pressure started less then 500psi now its getting to 500-1000+. My question is should I...
  8. 6.0L Problems Forum
    Hey so about 3 weeks ago I got a 2006 F250 superduty 6.0 powerstroke as an early graduation present from my dad. I’m 17 and it’s my first diesel my stepdad is familiar with Cummins bit not the Ford powerstroke. We got the truck for a very good price and he straight up told us that it had 2...
  9. 6.0 Motor problems
    Howdy! I'm new to the Power Stroke forum and a new owner of a 2004 F-250 with the 6.0 diesel engine. This is the first diesel I have ever owned, but I've been reading a lot of posts on this forum and have familiarized myself with this engine enough that I'm ready to ask what I believe will be...
  10. 6.0 Motor problems
    2006 f350 6.0 I've been having all kinds of problems with my hpop system. I replaced the STC,dummy plugs, standpipes, oil cooler, EGR delete, new seals and o rings on injectors, IPR, ICP sensor, EBP sensor, MAP sensor and blue spring kit. Issue #1Truck ran idled great went to drive I had no...
  11. 6.0 Motor problems
    Hi, I have a question about my truck(03 F350). No start issue. when I disconnect the FICM, the high pressure can go to 800 or 1000 PSI when cracking. but when I plug FICM in, now matter how I crank, I can only get ~400psi. hence now start. The FICM voltage is good at 48.5 and FICM sync is 1...
  12. 99-03 7.3 Motor Problems
    '02 7.3. I had the oil pan replaced a few years ago, and I've had issues, when the temp is below 40f. The HPOP is usually empty.. Once she starts, and temp comes up to normal range, she's good,for the day. Starting is a royal pain. She cranks, and starts, but oil pressure gauge shows no...
  13. 6.0L Problems Forum
    2004 f350 6.0 PSD late build, I was driving down the road pulling 14k trailer when engine decreased power and speed to the point it died and left me stranded. After couple hours it was a hard start and died after 20 seconds. Since then it has been a no start at all. It has plenty of fuel going...
  14. 94-98 7.3L General Powerstroke Discussion
    Good morning all! I am in the process of checking my oil pressure on my 95 7.3. Plugging my gauge into one of the ports by the valve covers, I'm getting about 6-650 psi at idle and when I floor it, it goes up to 2,500 psi for a few seconds and then drops to 1,500 psi. Is this normal? Thanks!
  15. 99-03 7.3L Powerstroke Problems
    I've got an '03 7.3 with ~230k miles. I had oil leaking out of the HPOP so last week I finally got around to resealing it as well as the fuel bowl. changed the oil, put it all back together, started up fine. Drives fine. But I get the CEL to kick on any time i'm pushing it and im accelerating...
  16. 99-03 Ford Excursion Forum
    Hi, I have a 2002 Ford Excursion 7.3 and it works pretty well but it has a very repeatable behavior that I am trying to diagnose. There are 2 modes of starting that it exhibits: 1) Starts on the 2nd or 3rd crank and 2) takes 1-2 seconds to crank (maybe 10-20 cranks). I am thinking that some...
  17. 6.0L Problems Forum
    Hi all, I have a 2003 Ford Excursion 6.0. If I forward park on a slope, it has issues starting and will have to try and start around 4-5 times before it will turn on (before that it will turn on for a second then off). If I back in to driveway (front downhill), then it starts fine. I'm guessing...
  18. 99-03 7.3 Motor Problems
    Hello, I recently changed injectors, cups, GPs and HPOP as well as rebuilding turbo, roughly 1K miles ago. I pulled my travel trailer(8000 Lbs) for the first time since all the changes and I have noticed something odd. While slowly letting off the pedal injector noise gets very loud for a few...
  19. 99-03 7.3 Motor Problems
    Hello, I have new injectors installed but I am having some starting problems, and just seeking some input. It starts fine when engine is cold but the hotter the engine gets the harder it is to start. Glow plugs are working, I had a new high pressure oil pump and IPR last month. It was starting...
  20. 99-03 7.3 Motor Problems
    Hello all, I recently had the HPOP replaced by a Ford dealer. ( Not by choice but was on the road and had no tools or time to do it myself). I have noticed intermittent blue smoke(and a lot of it) while driving. It does not matter hard or light acceleration. I can be cruising along at 70 or...
1-20 of 152 Results
Top