Ford Powerstroke Diesel Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 161 Results
  1. 6.0L Problems Forum
    Recently I created a post talking about how I think my hpop is bad. Well I decided to pull the pump andddd I can’t see anything visually wrong with it. A little back story: I bought an early 2004 6.0 a while back(the one with the ****ty hpop), it was long cranking but it still would start. On...
  2. 6.0L Problems Forum
    I bought an early 04 6.0 a while back, it was running great and all of the sudden my oil pressure dropped to zero at idle. It also started to have a long crank and took about 7-8 seconds to start whereas it used to only take 1 or 2. Obviously it still had oil pressure or else it would not be...
  3. 6.0 Motor problems
    I have a 2005 with a completely stock 6.0, 213k, and what i think is the HPOP, went out on me the other day. When the engine is cold, it will fire up right away. The problem happens when I drive somewhere and shut my truck off. When it's up to temp it won't start. For example, I could turn it...
  4. Powerstroke.org Builds & Projects
    so getting a 2006 6.0 today with 237,000 miles give or take (i have not seen the truck mind you). the owner has stated that the truck has sat for 1 year in a shop yard. mechanic states that oil pan has metal flake in it not gold or bronze. oil pan has not been removed either. when I called the...
  5. 99-03 7.3L Powerstroke Problems
    Had a oil leak on my 7.3 replaced the turbo deck , resealed the hpop , new ipr ,resealed the hpop resevoir , new hpop lines in which I had to eliminate the plungers replaced the valve cover gaskets , new glow plugs .Truck ran perfect before I replaced the parts .When I restarted it I noticed a...
  6. 6.0L Problems Forum
    To your point with the harness, so I have an 04 f250, I put it back together after rolling it over (new cab and bed) had some minor wiring issues reverse lights stay on, blend door doesn’t actuate (I replaced the vacuum pump and module), fuel gauge isn’t working likely the wire in the tank, now...
  7. 99-03 7.3L Performance Parts
    So, my factory lines at 170k mi, were leaking at the seals. I thought, hey why not replace them? New lines came with fittings and a xover line, which I did not use or care to discuss, but after initial install began leaking at same fittings. Now after 3 X r&r LEAKING! Has anyone tried replacing...
  8. 99-03 7.3L General Discussion
    So I have a 1999.5 7.3l powerstroke I’ve changed my icp, my ipr, and my cam sensor was running good after I changed my icp was driving it all around town until I cut it off at the last store on my way home it wouldn’t crank so I changed the cam sensor started up got me home cut it off then tried...
  9. 6.0 Repair Help
    I’ll take any advice whatsoever on this whole mess. I have 165k on a late model 04 f250. Recently ran into the old hot no start issue. I changed dummy plugs and standpipes, new valve cover gaskets, replaced mesh and o-rings on IPR, ICP was replaced in the last 10k miles, injectors replaced in...
  10. 6.0 Motor problems
    Looking for some help with standpipes. I’m on my 3rd set in 12 months I keep blowing the o rings. I’ve replaced with AVP updated one but they keep failing, just curious about what could be causing this and if I should just get the motorcraft ones. I keep using the avp because they warranted them...
  11. General 6.0L Discussion
    On the 6.0 HPOP update kit, the updated STC fitting has 3 holes(2 bolt holes). Why does the updated fitting have 3 while the old one has 2(just for the bolts). I’m trying to track down a high pressure oil leak and noticed while sending air through the system that all the air is coming out of it.
  12. 6.0L Problems Forum
    I just replaced the injectors, stc fitting, standpipes, dummy plugs, and oil cooler on my truck. I have tried probably 20 times to crank the engine over by jumping the starter solenoid to prime the oil system. There's no codes, the fuel filter and oil filter housings are filling, there's good...
  13. 6.0 Motor problems
    Nearly there - new injectors, glowplugs and was ready to replace STC fitting but someone had been there before. Must had dumped a few crumbs under the HPOP oil cover and had a blocked IPR screen - replaced that (diagnosed with autoenginuity) maybe need to go in and do another screen replace...
  14. 99-03 7.3L General Discussion
    Hey guys, 1999 f250 7.3 zf6. Thing starts when cold pretty well but as soon as it warms up has slow throttle response and doesn’t restart. Checking the icp it it’s only making 350-400 when hot. Replaced IPR and ICP, charged high pressure system with shop air and there’s no apparent leak. Double...
  15. 6.0 Motor problems
    Greetings folks. I have read many forums over the years and usually can get things fixed by the wisdom shared. I haven't found anything like this anywhere and now need an answer that hopefully someone can provide. Just replaced my head gaskets... put it all back together and had it idle for...
  16. 6.0 Repair Help
    I just replaced the OEM oil cooler with the BPD oil cooler kit. I did not fill the valley back up to prime the HPOP. When I crank the engine ti start I read good FICM Sync, good IPR, good ICP voltage, hpop pressure started less then 500psi now its getting to 500-1000+. My question is should I...
  17. 6.0L Problems Forum
    Hey so about 3 weeks ago I got a 2006 F250 superduty 6.0 powerstroke as an early graduation present from my dad. I’m 17 and it’s my first diesel my stepdad is familiar with Cummins bit not the Ford powerstroke. We got the truck for a very good price and he straight up told us that it had 2...
  18. 6.0 Motor problems
    Howdy! I'm new to the Power Stroke forum and a new owner of a 2004 F-250 with the 6.0 diesel engine. This is the first diesel I have ever owned, but I've been reading a lot of posts on this forum and have familiarized myself with this engine enough that I'm ready to ask what I believe will be...
  19. 6.0 Motor problems
    2006 f350 6.0 I've been having all kinds of problems with my hpop system. I replaced the STC,dummy plugs, standpipes, oil cooler, EGR delete, new seals and o rings on injectors, IPR, ICP sensor, EBP sensor, MAP sensor and blue spring kit. Issue #1Truck ran idled great went to drive I had no...
  20. 6.0 Motor problems
    Hi, I have a question about my truck(03 F350). No start issue. when I disconnect the FICM, the high pressure can go to 800 or 1000 PSI when cracking. but when I plug FICM in, now matter how I crank, I can only get ~400psi. hence now start. The FICM voltage is good at 48.5 and FICM sync is 1...
1-20 of 161 Results
Top