Ford Powerstroke Diesel Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 30 Results
  1. 6.4L Problems Forum
    Hey group. I am new to this and new to diesel engines. I purchased this truck for my 17yr old son. It has about 162,xxx miles on it. All stock. I suddenly got a bunch of codes and it runs bad. The codes are: P0266 P0281 P0673 P0302 P2291 P115A B1318 U2472 U0100 C1170 C1446 B2900 U2011 I know...
  2. 94-98 7.3L Problem Forum
    Hello everyone So long story about this one... Neighbor in Alaska had this 95 F-350 with the 7.3 and the 5 speed sitting in the yard since 09' was able to get it started with some new fuel, 911 and batteries! only thing I needed to replace was the water separator and starter solenoid. So I get...
  3. 6.0L Problems Forum
    The truck has been fine for a while now but all the sudden I have a check engine light with a code P0197, when I turned the key to start it again the glow plug light came on then off then back on... Now it's 75deg outside and I can't start the engine without substantial crank time. I piggy...
  4. 6.0 Motor problems
    Hey guys, new to the forum and have a question. I recently picked up a 2006 f350 with the 6.0L Powerstroke in it as a summer project, and I'm getting a crank, no start condition (cold). This is my first 6.0 so help is much appreciated! Truck/Conditions info: 2006 f350 6.0 factory head bolts...
  5. General 6.0L Discussion
    Greetings! My 2005 F350 has 100,000 miles on it and the computer is throwing code P0671 without the CEL. I just happened to scan for codes and it came up otherwise I'd never had known there was an issue. I haven't Ohmed it out yet but assuming it is the plug should I replace all of them or...
  6. 99-03 7.3L Powerstroke Problems
    Sorry if this was already covered I’m new to this website 02 7.3 power to the glow plug solenoid 12v ground is good but only 1v to signal wire when I run a jumper wire the solenoid clicks and Carry’s the current through I’ve replaced the left side plugs and harness all ohm out to .2 ohms...
  7. General 6.0L Discussion
    I am getting ready to replace the glow plugs on my 2006 F250. From my understanding, without taking off the cab, it is easiest to go through the wheel well. Is this completely true? Also, I will be replacing the harnesses since I have read that the old ones will most likely break from removal...
  8. General Diesel Discussion
    So I had whitish bluish smoke ONLY on start up and a few minutes after when the engine was fairly cold, so I replaced the glow plugs and a whole list of things which took just over a month. I had trouble with glow plug on number 6 cylinder it was stuck in due to carbon (I finally got it out) and...
  9. 6.0L Problems Forum
    So I bought cheap glow plugs last year and of course they failed (should have listened) so I bought motorcraft plugs and harness. One glow plug came out with ease and the second glow plug felt like it was coming out with ease but just keeps spinning and spinning, I used a 1/4 inch ratchet and...
  10. 6.7 Problems Forum (2011-2016)
    Reaching out for some help since my dealer can't seem to find the dang issue! I have a 2016 Platinum F-250 with 75K miles. This truck has been in and out of the shop since I bought it months ago. After my first oil change and fuel filter change my check engine light started popping on and...
  11. 6.0 Motor problems
    I am on my first diesel truck a 2004 F350 Super Duty. It is a 6.0l Diesel with 120K miles. My issue started last week with the WIF and Glow Plug coming on for about 2-5 seconds. When that happened the truck dropped to an Idle. Once the lights went out, the power was restored. This happened 1...
  12. 6.0L Problems Forum
    Hi guys, This is my first post on here, although I usually just stalk the forums to find all the answers I'm looking for however, I can't seem to find an explicit answer this time. I bought the truck in August of this year and immediately deleted the EGR cooler and replaced the oil cooler as...
  13. 6.0 Motor problems
    Soo things have been getting pretty cold here in jersey and the mornings have been really rough on the truck. Thought i had a GP problem so went out and bought a GPCM after doing some tests with the multimeter. Didn't solve my problem so asked a buddy to pull my DTCs and all 8 have popped up...
  14. General 6.0L Discussion
    Hi everyone .... I have an 03 250 with 200k mi. Has been running and starting just fine until the weather changed. I'm in Northern Calif, so its not super cold, nonetheless, I have to turn the key and hold it for 10 to 15 seconds as the engine cranks, finally it starts and a large puff of smoke...
  15. 6.0L Problems Forum
    im working in a 2004 6.0 the truck is difficult to get started in colder weather hooked up ae,checked battery voltage,icp,ficm voltage everything checked out good. But there are trouble codes for glow plug circuit failure on all glow plugs except for number 3.I replaced the gpcm thinking that...
  16. 6.4L Problems Forum
    Hi guys, I just got a P0672 code and will be replacing the #glow plug... so first off, does anyone have any tips on the easiest way of accessing it. I took a quick peek tonight and it doesn't seem to bad if I remove the antifreeze tank. Secondly, I have been reading about this code and some...
  17. 99-03 7.3 Motor Problems
    My truck is a little hard to start lately, new stancor gpr and glow plugs. Not sure the problem, and ideas? It has been in the 70s and 80s, not hard to start after warming up, but the initial starting is like 5-10seconds. Mornings I usually have to try 2 times to start.
  18. 94-98 7.3L Problem Forum
    I am having trouble getting my 79 Bronco with a 95 Powerstroke Turbo Diesel started. I am thinking it is the glow plug relay, so I tested it today. Here are my results: You can see which post I am testing in the picture, with the voltage I am getting. Please keep in mind that my...
  19. 99-03 7.3 Motor Problems
    My truck will not start (turns over) unless I plug it in for a couple hours. When it fails to start, it seems to be trying to run on less than 8 cylinders and produces white smoke. When plugged in, it starts and runs fine. I replaced the gpr with a Stancor. I checked the glow plug...
  20. 94-98 7.3L Problem Forum
    Ok, I have spent some time trying to find an answer without posting. But there are several factors to all this. Yesterday afternoon, I heard a noise that sounded like something was rattling in a fan. I was very worried, but thought maybe something got in my air intake. By the time I got home...
1-20 of 30 Results
Top