Ford Powerstroke Diesel Forum banner
ebps
1-5 of 5 Results
  1. 6.0L Problems Forum
    Ive seen some others who have ran into the same problem as me but have not had any answers as to why I'm still having this problem. I replaced my fuel filters, the map sensor and hose, the EBPS sensor and tubes, the EGR valve. I only have power when its hot and when i do it still flutters at...
  2. General 6.0L Discussion
    I’m looking for some clarification on what I should be seeing for the EBPS. I have a 06 and about a month ago I pulled the sensor to find out it was fully clogged. I replaced it, and removed/cleaned the pipe. After that I got my hands on a livewire and with KOEO I get EBPS 3.56 bar, MAP 0.85...
  3. General 6.0L Discussion
    I just got a 06 F250 and the prev owner had a livewire that ended up having issues. I sent it into SCT for repair but they couldnt fix it so they sent me out a newer version (at a cost) to replace it. The replacement unit arrived and i waited for tech support to walk through pulling down the...
  4. General 6.0L Discussion
    Hey guys I’m new to powerstrokes so bare with me if I’m missing something obvious. I just picked up a 06 F250, it started and ran fine for a week then the temps dropped down to 20f and when I went out to start it I got no crank. Left for work and ignored it until the next day when it was 45f...
  5. 6.0 Motor problems
    Got MIL for EBPS monday(12/31) pulled off the tube cleaned, stuck a pick up into the elbow type thing and pulled out some carbon buttoned her up and drove. Noticed surging this morning checked for codes and i have p0069 map/baro correlation. Pulled EBPS on lunch(hoping still had carbon) sure...
1-5 of 5 Results
Top