Ford Powerstroke Diesel Forum banner

ebp sensor

  1. General 6.0L Discussion
    I'm getting 8-12 PSI at 55mph. 3-4 PSI at hot idle. What is this a symptom of? *I swear I've been searching for an hour with no luck. Sorry if this is common knowledge. Any help is appreciated.
  2. 6.0 Motor problems
    I replaced my thermostat a couple days ago and when I did I had to pull my EBP sensor bracket off to get to it. While I had it off I took it apart and cleaned it out with just a dry Q-tip, and then kinda scraped out the elbow it connects to with the Q-tip stick, quite a bit of gunk and crusty...
  3. General 6.4L Discussion
    Ok after dealing with a frozen EBP sensor for the better part of a week now I decided I needed to move the sensor down to the delete plug. Found most of the fittings I needed at a local store so I decided to try it tonight. First thing I noticed was rust on the bottom of the plug. Dismissed...
  4. General 6.0L Discussion
    Recently recieved and installed an Edge CTS in my 2006 6.0 and have been monitoring pid's. From what I understand BARO, MAP, and EBP should indicate atmospheric pressure (14.7psi at sea level) and read within 0.5 psi of each other, Key On Engine Off. My EBP reading at KO,EO says 0 psi. About 2...
  5. 6.0L Problems Forum
    I will start by sayin i am a Newbie to the diesel world, and im only 22, but some what mechanically inclined, i can do simple stuff.... so on to the problems... I have been having drivability problems with my '04 f250, it would be kind of sluggish in the low end and after, say 45, there would...
  6. Engine 911
    trid to clean mine today.... found out in had cracked..... anyone know here i can get one specific to a obs??? i can find the 99 sd tubes no problem please help!!
Top