Ford Powerstroke Diesel Forum banner
cooling system
1-7 of 7 Results
  1. 99-03 7.3L General Discussion
    Does anyone have history with the Rudy's degas aluminum tank for a 7.3? Needing to replace mine and just looking around. I've looked at other aluminum tanks and just can't see spending $350 for one if a $175 one will just as good. Comments please.
  2. 6.0 Motor problems
    03 6.0l F250 4x4 auto Finally installed Edge Insight engine monitor which pointed out an problem I didn't know I had. It shows error code PO480 which is the Cooling Fan Relay. Does anyone know where this is located or what the replacement ordering part number is? I didn't know I had a...
  3. Engine 911
    2002 250 7.3 i have replaced the radiator and the water pump and the the thermostat and the coolant resivour and something is causing it to leak coolant either through the resevoir cap or the radiator where the plastic meets the aluminum im stumped my only thoughts are there is a bubble in the...
  4. 99-03 7.3 Motor Problems
    i got a 2002 3/4 ton 7.3 was leaking coolant so i traced it to a bad thermostat decided to put a new water pump in then the radiator started leaking so i put a new one in then the resivour started leaking put a new one in and now the brand new radiator is leaking in the same spot as the old one...
  5. 6.0L Problems Forum
    I've had two radiator hoses burst on me in the last three weeks. I don't know if my water pump is going bad and over pressurizing or what. The first time it was the upper radiator hose and I was just going about 60mph down the highway, not accelerating or anything. The second time it was the...
  6. 6.7 Motor Problems (2011-2016)
    I have a 2011 550 30,000 miles, just recently the engine fan started running almost all the time. Engine temp. reads normal,coolant is OK ,oil is OK. Ford dealer says nothing is wrong. "No codes" .....any Ideas ? Thanks
  7. 99-03 7.3L General Discussion
    I have over heating problems!!! I have a 2000 F350 4x4 that i purchased about a year ago. The truck has about 280K miles on it and i have already flushed the cooling system once. I have had no issues until around june of this year i noticed that when i pull my dinky little work trailer (6'X8')...
1-7 of 7 Results
Top