Ford Powerstroke Diesel Forum banner

burning oil

  1. 99-03 7.3L Powerstroke Problems
    Hello all, to start off I'm new to the forums, and I just got this truck and its been burning oil.. A lot of oil, at the rate of about 2qt/100miles. A little background on the truck, it has 310,xxx miles on it, the previous owner installed 80% over injectors, a d66 turbo, and a ts6 position chip...
  2. 7.3L IDI (Non-Powerstroke) Diesels
    Hi there! New to the forum and new to a 1994 7.3 IDI diesel w/ factory turbo with 240k. I have read quite a bit on these awesome forums, and am pretty sure where I stand, but am really interested in the opinions and thoughts of the many knowledgeable diesel gurus here! Your thoughts on the...
  3. 99-03 7.3 Motor Problems
    so i changed my oil tonight, its been about 7k miles since ive changed it. i drained the oil and put 15 quarts in, but when i poored my old oil in the containers and i only got 10-12 quarts back. is this normal or bad??:dunno: (old stuff was 15-40 royal purple btw)
  4. 99-03 7.3 Motor Problems
    I am new to this forum thing, but I need some help. Recently bought a 01 7.3 with 143k on it. Hadn't really been driven much for a few months before I bought it. I replaced an injector in it and Ford said the truck was good to go. Drove it out to school (600 miles) no issues. I start it a few...
  5. 99-03 7.3 Motor Problems
    2001 7.3 with 130,000 miles started using 1 quart of oil every 100 miles. No visible leaks - not a drop on driveway. No loss of power, good compression. Exhaust smells like burning oil and has blue tinge. Recently replaced turbo with no change in oil use. How is oil getting into the cylinders...
Top