Ford Powerstroke Diesel Forum banner

7.3 powerstroke problem

  1. 99-03 7.3L Powerstroke Problems
    I have a 2001 Ford F-250 lariat crewcab 4x4 With a 7.3 power stroke with 340000 miles and I have a issue we’re if I hit the gas on the truck I hear a loud hissing sound like if air is leaking and don’t know what it is? Can someone help me
  2. 99-03 7.3L Powerstroke Problems
    Hello everyone! We were just traveling in our bus, 2001 E-350 super duty cutaway, 7.3L Powerstroke, when it suddenly lost power going uphill. Started rattling and shaking, barely made it past 25mph. Not a rattling sound, more of a bumpy ride, as if the engine didn't get enough fuel. I pulled...
  3. 99-03 7.3 Motor Problems
    I have a 2002 F250 7.3. Yesterday I was driving away from a stop sign, softly accelerating, and all of a sudden a crap load of smoke started billowing out the tailpipe and a knocking sound started on the top end on the passenger side. My injectors have been going bad for a while, I just haven't...
  4. 94-98 7.3 Motor Problems
    Hi guys, im having an issue with my 1994.5 7.3 powerstoke, and wondering if you could maybe help me diagnose the problem. It sounds pretty good when idling, maybe slightly rough but not to bad. the truck is just pouring out blue smoke on start up and is consistent for about 10 minutes, and...
  5. 99-03 7.3L General Discussion
    Hi terry here from australia First time user hope that I have done it right I hope that there is someone out there who can help me I have a 2002 f250 4x4 auto It h as the 7.3 turbo powerstroke in it It had done some 500,000 ks My problem is that when I start it up cold it idles fine but when...
  6. Diesel Diagnostics
    I have a 99 f350 6spd 7.3 Im at a loss trying to figure out a problem I bought the truck with all new injectors in it and it blows white smoke (fuel) when im running threw town and runs ruff . When I get out on the highway it runs fine with all the power in the world. It keeps kicking codes for...
  7. Diesel Diagnostics
    Hi, I have a 1999 f250 powerstroke. It has a skip and hard to start. Codes says bank 1 and 2 are open and cylinder 3 and 4 is out of balance. I've put new valve cover gaskets and injector wires. Changed #4 injector with #2 and nothing has changed. Any ideas on what could be wrong?
Top