Ford Powerstroke Diesel Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 500 Results
  1. 6.0 Repair Help
    I have made a post about about this before, but never had the video until now. When cold starting regardless if it’s hot or cold outside my 2005 6.0 stumbles when starting as well as takes a little longer to crank. Batteries were just replaced, ficm says 49-48.5. Truck runs great and starts time...
  2. 6.0L Problems Forum
    I have a 2004 F-250 6.0 with 150k miles I’ve had this truck for about a year now and never had any problems with steering. It’s got basic stock components but everything looks decent. I need to replace brake pads all around but the problem doesn’t sound like it’s coming from the brakes. The...
  3. 6.0L Problems Forum
    Hi guys I have a 2006 6.0 and just received my sct x4 and I plugged it in and tried to program my vehicle and it says my trucks not supported. Everything else works but it won’t give me the pre loaded tunes. Also I tried registering it on sct website and it says my serial number can’t be found...
  4. 6.0L Problems Forum
    I can start driving my truck and for a bit it will be fine but then it falls flat on its face has barely enough power to get down the road I drive an 2004 excursion 6.0 and when it acts up it bellows black smoke then a few hours later it runs normal and no smoke but it doesn't last long till it...
  5. 6.0L Problems Forum
    2006 f250 6.0 with 170k on the dash. I have a few issue at this point and not sure if any of them are related to one another. Okay so my turn signals all went out the other day after using my hazards for a couple mins I tried using my blinkers and nothing. Can’t hear the relay inside and they...
  6. General 6.0L Discussion
    Hello everyone, I would appreciate your help and input regarding my 6.0 Rebuild. I am looking to do a reliable yet enjoyable build I have compiled the following list: 1. Full Engine Gasket Set 2. Engine Oil Cooler 3. Stand Pipes / Dummy Plugs 4. (6.4) Push Rods 5. Injectors 6. Glow Plugs 7...
  7. General 6.0L Discussion
    I need to get this issue sorted out for ca smog. My truck was throwing p0401 code for insufficient egr flow. I used forscan to monitor pids and saw egr desired didn’t match egr actual. Replaced the egr valve yesterday with a new OEM valve and have the same issue. Recently had it bulletproofed...
  8. General 6.0L Discussion
    Hey guys, quick question, can you reuse apr head studs? I’m in the middle of having everything rebuilt and the truck has “apr 2000” head studs currently. Can I reuse them with confidence? Also, is there a “best” head gasket that’s less likely to blow? Trucks been through 3 sets of head...
  9. 6.0 Motor problems
    I noticed that I’m leaking diesel from or around my exhaust manifolds. I read this could be stuck injectors, but I’m not throwing any codes and there is no loss of power, and no mixing of any fluids or other signs of a blown head gasket. does anyone have any ideas on what it could be?
  10. 6.0 Mod Help
    Bought an 05 6.0 bulletproofed stage 2 trans with tune new turbo and injectors with max custom tune tracs bars ect ect The tune is an ecm tune so I was wondering if I could plug a monitor into the obd2 without messing that tune would love live data though and what upgrade would u recommend for a...
  11. General 6.0L Discussion
    I have the 7.3 fan clutch conversion and its working well, but it's hot here. I mean 105 to 115 and the clutch seems to be my A/Cs cryptonite. I have a completely brand new ford oem A/C system that has been charged twice as when at a light or if standing still the A/C gets warm while moving its...
  12. 6.0 Motor problems
    I have a 2005 with a completely stock 6.0, 213k, and what i think is the HPOP, went out on me the other day. When the engine is cold, it will fire up right away. The problem happens when I drive somewhere and shut my truck off. When it's up to temp it won't start. For example, I could turn it...
  13. 6.0L Problems Forum
    Last week I installed a new turbo wheel and did the 360 thrust bearing and rebuild from KC turbo. After but the truck back together on start up it blows white smoke. Had no issue like this before rebuilding the turbo. Truck sat for a week when doing the rebuild due to work.
  14. 6.0L Problems Forum
    I have a 05 6.0 f250 and I’ve recently had some work done to it. That includes being fully bulletproofed, full turbo back 4in exhaust, 155cc injectors, and a tune. The turbo started whistling as soon as I got it back, it only this specific noise from about 1-3 pounds of boost. It’s also maxing...
  15. 6.0L Problems Forum
    Hello, I have a late 04 stock 6.0 f350 crew cab 4 wheel drive. The problem I have is the boost drops out when at temp and trying to accellerate and RPMs try to go over 2k rpms. When i try to accellerate at temp it pumps smoke and I smell unburned fuel. If I slowly accellerate I hav no issues...
  16. 6.0L Problems Forum
    I have a 04 6.0 Ex. Intermittent no crank when the truck is hot. Hasn’t happened cold yet. Turn the key and some of the dash lights turn off. Stereo and check engine light stay on. If I wait a little bit it will crank right up. No codes. Don’t think it’s the park switch. I’ll not crank in...
  17. 6.0L Problems Forum
    Hey everyone been awhile but here we go again lol. I’m getting ready to do the oil cooler, flush coolant, replace y pipe and rebuild my turbo all by myself… anyone got any tips or tricks for me. Thank you son advance!!!
  18. Powerstroke.org Builds & Projects
    so getting a 2006 6.0 today with 237,000 miles give or take (i have not seen the truck mind you). the owner has stated that the truck has sat for 1 year in a shop yard. mechanic states that oil pan has metal flake in it not gold or bronze. oil pan has not been removed either. when I called the...
  19. 6.0L Problems Forum
    came out to start my truck up about a week ago, started but ran rough and had 0 fuel pressure in the bowl. Shut it off, checked all connections, everything seemed fine. So, I had a napa hfcm pump laying around so I took it and returned it as defective for a brand new one. Put it in, still no...
1-20 of 500 Results
Top