Ford Powerstroke Diesel Forum - Reply to Topic
6.7 Problems Forum (2011-2016) 6.7 Problems Forum

Thread: 6.7 fan clutch went Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-23-2011 06:08 PM
"Stroker 8"
10-06-2011 09:30 AM
"Stroker 8" Any Updates?
09-13-2011 05:01 PM
strivingfirst So what happened, did you have to eat the cost?
Hope it worked out for u,
Dom
08-15-2011 09:39 AM
normsled that's exactly what they are saying. Pushing it up the ladder right now. My dealer tells me they covered it under the 6.0 and the 6.4, but not the 6.7. Why?
08-15-2011 09:22 AM
Rob Part of the engine right? Should be covered unless they throw the "it's not an internal mechanical part" at ya. Good luck!
08-15-2011 08:58 AM
normsled
6.7 fan clutch went

Just turned 63,500 on my 2011 crewcab and the fan clutch went. truck was flawless so far. Delaer just called and it is not covered under warranty!!! $700 bill and he is doing it for cost to try to help. On hold with Ford Customer Service as I type this. We'll see.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome