Ford Powerstroke Diesel Forum - Reply to Topic
6.7 Problems Forum (2011-2016) 6.7 Problems Forum

Thread: Leaking oil in cab under dash Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-10-2011 07:19 AM
Ren
Quote:
Originally Posted by Geodude View Post
I had that, and it was some lube dripping off the brake pedal assembly. Cleaned it up a few weeks ago and it hasn't been a problem since. I think it was just over-lubed.
Yep..I had one or two drips. Took a rag and wiped up some excess and its all good now.
05-09-2011 02:55 PM
haccpguy I have this problem on my 2010. I am told it is excess grease coming off of the adjustable pedal assembly. It is definitely more grease like than fluid. I have had the problem intermittently for about 1 1/2 years.
04-21-2011 06:46 PM
extreme26 Thanks. Thats what I was hoping for a easy fix. I really don't like taking it in... Seems like it always comes back out of fuel and still broke the first few times befor the figure it out! Thanks again
04-21-2011 04:50 PM
Geodude I had that, and it was some lube dripping off the brake pedal assembly. Cleaned it up a few weeks ago and it hasn't been a problem since. I think it was just over-lubed.
04-21-2011 12:36 PM
TexasAggie09 This is a 2011? Take her back to the dealer!
04-21-2011 12:12 PM
extreme26
Leaking oil in cab under dash

11 f250 and its leaking oil on my floor mat on the driver side?? looks like its coming off of the break peddle??? anyone have this prob?? i have 6000 miles on the truck

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome