Ford Powerstroke Diesel Forum - Reply to Topic
General 6.7 Discussion (2011-2016) General 6.7 Discussion

Thread: A fellow members suggest I post here Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-20-2019 05:52 PM
Old King Coal As mentioned above, you need the tune that was installed on the truck before you loaded the GTX. Please tell me that the tuner captured it as the ‘stock’ tune. If it did just reload the tune it captured as the stock one and you should be good to go. Otherwise you’re going to be in a bind.
10-20-2019 11:44 AM
Larry1013 did you save the old tune when you hooked up the SCT GTX? If not, you are screwed and will have lots of headaches if you can't find the previous owner and get the tuner they used and then, you might be in for a lot of hassle to get it out of the limited power mode.
10-20-2019 10:04 AM
Andy79
A fellow members suggest I post here

Hello and thanks for your time, I'm new to the site as well to the diesel world.
I recently purchased a SCT GTX & a 2015 powerstroke 6.7 super duty. Since I hooked it up the truck throws a "exhaust fluid system fault" which has the truck stuck in limp mode.
The truck did have a previous owner who put on a 4 inch turbo back straight exhaust & I'm to new to know if they did anything else.
Then the only thing I did was add a K&N filter to the air box.
The truck ran great no issues until I installed the SCT GTX. Any help would be appreciated.
Thank you for your time

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome