Ford Powerstroke Diesel Forum - Reply to Topic
6.0L Problems Forum Having Trouble? Post here

Thread: Coolant Puked again...a little Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-07-2019 06:40 PM
ChrisSki Nice and shiny.

Both links work fro this computer.
10-07-2019 05:12 PM
brazosdog02 I think they are working now.
10-07-2019 09:32 AM
ChrisSki
Quote:
Originally Posted by brazosdog02 View Post
Here is my mishimoto after towing for 2 weeks:

https://bit.ly/30TnLgH
The link doesn't work for me. May be the security settings on my browser.
10-07-2019 09:28 AM
brazosdog02 Here is my mishimoto after towing for 2 weeks:

https://bit.ly/30TnLgH
09-22-2019 06:21 PM
brazosdog02 Here is my temperature log from today. About a 3 hour trip, flat road, 95 degree ambient on average, unloaded. Look at the temperature swings. What do you make of this? Also, note the time spent near the end of the trip in the 170's.

Unloaded

Same Chart with Additional Sensors

TOWING 6,000 Travel Trailer, 95-100 degrees ambient, mostly flat terrain.

Towing

Same Chart with Additional Sensors

The last portion of the "Towing" must have been when I was idling. Still, not a temperature I expect. Also, not sure about the "0" in there, but its only one, so It's probably a glitch in Torque or something.

All sensors seem to track with coolant temps. Don't worry about the EOT Delta, its BPD Oil Cooler.
09-21-2019 09:13 AM
barongan Tagged, this seems like a very interesting thread
09-21-2019 07:45 AM
brazosdog02 Just thought I would post that I was trying to get the serial number of the radiator and I cannot see it. The sides of the radiator, which used to be perfectly vertical are BOWED out about 1” on each side. Not even sure if I can get it back out.

Dude. What in the holy crap? I don't know how you build that much pressure and don't pop a cap or explode a degas bottle, but this must be why the lower hose blew. There must be some sort of crap in the radiator or slag or something that allowed it to build, balloon the radiator and not explode it.
09-15-2019 08:38 AM
Hartwig To find the issue, I'd drive without a thermostat.

Maybe that's an alternative. My stock radiator is now 13 years old. It is still ok, but I have a camper vehicle for long journeys and would get very difficult spare parts abroad, I exchange it as a precaution.

https://www.iprresearch.com/IPR-Extr...Excursion.html
09-14-2019 07:47 AM
brazosdog02 I have never run without a thermostat and for the cost of a new one, I'm not willing to test it out. I think I can save a lot of trouble here by getting a new thermostat and putting a brand new OEM radiator in. The OEM tstat is less than 1 year old. There are a few things on this truck that OEM is not quite as good as aftermarket, but the majority of it, the Ford Engineers got right. My extensive reading here and elsewhere has lead me to see that the OEM radiator is superior to any aftermarket in pretty much every single category except for the end tanks, and mine didn't leak for 150,000 miles. Mishi is refunding my money anyway and its just not worth the risk to test out the Chinese built "Performance Radiator". I contacted them a week ago, and they have not responded at all so that tells me that I won't be getting any support from them if it doesn't work. Plus, there is no guarantee it will even arrive in decent condition and I am not paying BPD twice the price for them to put it in a fancy box.
09-14-2019 05:14 AM
Hydro Without a thermostat, the coolant does not follow the intended path thru the block and heads -- the thermostat not only controls temperature, it also controls coolant flow path

Thermostats are never really fully open or closed(except when cold), mostly they are somewhere between
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome