Ford Powerstroke Diesel Forum - Reply to Topic
6.0L Electronics Discussion TV's, Radios, everything electric and NON-Performance.

Thread: only ONE brake light Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
08-23-2019 10:59 AM
ChrisSki If this happens again, you can check for corrosion on the connectors at the taillight, also along the wires as far as you can trace them. Way you describe the fix, maybe a relay. I had a trailer light problem that was corrosion on the male end of the plugs.
08-21-2019 08:29 AM
TheOne problem solved

I messed with the hazard button, and somehow the drivers side brake light started to work.

08-21-2019 07:45 AM
TheOne
only ONE brake light

My driver's side brake light is not working when pressing the pedal.

I put a new light bulb in and no luck. The passenger side is working, I took that plug and put it on the drivers side and the light does not work when pressing the brake pedal.

I have checked all the fuses, both in the cab and under the hood.

Any idea's of what to check to fix the problem? Has anyone had this problem before?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome