Ford Powerstroke Diesel Forum - Reply to Topic
6.7 Problems Forum (2011-2016) 6.7 Problems Forum

Thread: What are the symptoms of a failing high pressure fuel pump? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-05-2019 07:57 PM
Nickjames525 Pull the upper and lower intake manifold off and pop the regulator out and see if there’s metal on it.
Also I’d cut the oil filter open and search for metal because no cp4 is going to lock the engine up. Any time I’ve heard a 6.7 make noises like that it got an engine. However, I had an lml that the customer said it squealed as well prior to dying... it’s currently getting a fuel system. Cp4 had come apart.
07-04-2019 11:25 PM
zerim5000 Can you share a video of you trying to start it? The symptoms you listed could be a fuel pump failing, fuel filter clogged/ not sealed, bad sensor(s), internal damage, or a long list of random things from a shorted wire in a harness to a cracked injector or bad control module.
07-02-2019 05:01 AM
druston I would start with the fuel filter. I've changed them out and everything seemed fine...until I put a few miles on it and got the low fuel pressure warning. If that green o-ring isn't lubed well with a little oil, oftentimes it won't seal.
06-09-2019 11:28 AM
Mikeb2015 Hi, did you ever figure this issue out?
12-11-2018 11:22 AM
phinzor
What are the symptoms of a failing high pressure fuel pump?

Short version: 2014 f250 takes about 10 seconds of cranking to finally build 5000 psi fuel to start. when it starts it runs really rough and makes a squealing + knocking sound like a spun rod bearing. Truck started fast and ran fine then this suddenly started. Is this a failing high pressure fuel pump or something else?

Long version:

I have a 2014 f250 that I just picked up from auction so i dont know the history. It started quickly and consitnely for a couple days in my shop, no obvious issues. First test drive it was driving fine down the road for about 3 miles then i slowed down to pull a u turn and the truck just died, no sounds. tried to crank it and the engine acted like it was locked up. only code was a cylinder 3 contribution code. I pulled the 3 injector and tried to crank engine, still locked. 2 new batteries, still locked. waited till the next day then the truck started to crank "fine" but would not start because low fuel pressure. after lots of cranking it did start but runs very badly.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome