Ford Powerstroke Diesel Forum - Reply to Topic
Thread: Help code P0231 Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
06-26-2019 10:56 AM
Zack Vogler Well it was the fuel pump. I appreciate it
06-19-2019 02:59 PM
Zack Vogler It is all stock and I changed the icp,ipr and camshaft sensor last year as well as the #8 injector. I'm going out tomorrow to look at it. It has been storming hard here for the last several days and I couldn't pull my truck in the garage with the tractor the other day
06-19-2019 04:51 AM
NoRalPh My usual No Start -

WTS Light? - do you get it when you first roll-on the key? (shows the computer is running)

Will your code reader show RPM, can you verify you have Cranking RPM as you try to Start? Do you have a spare CPS to try?

Is there fuel in the fuel bowl now? Does it refill after cranking? (open the drain lever to check) Look above the pass ft tire, you'll see a 3/8" metal tube, against the motor that ends there, it's the drain for the bowl (yellow lever you slide to the side). Get a cup, open the lever, drain the fuel bowl, look at the fuel, close the lever. Then, turn the key to the ON position (should hear the pump) for 15 secs. Drain the fuel bowl again, whaddya got?

Can you hear/feel the pump running (below the dr seat, against the framerail)

Could the fuel gauge be giving a bad reading? (Below 1/4 tank?)

Is it cranking fast enough? - it won't even TRY to start if cranking too slowly.

Is your truck "chipped"? If so, remove it as a Test.

You can unplug the ICP sensor, as a Test, so the PCM sets a default value for the IPR to run on (expect this to set a new "Low ICP" code, don't let that misdirect you after a scan).

Did you check the plug and sheet metal nut going to the IPR? That nut can vibrate off and allow the solenoid going over the valve to slide around. The wires going to the IPR can get brittle, crack, and short together. Make sure the plug & wires look in good shape.
06-19-2019 04:47 AM
White_Buffalo7.3 That code comes back as fuel pump relay. Try to measure voltage at the pump(under driver seat in the frame rail) or pull the filter and see if it fills up the bowl.

If you have voltage but the pump isn't running you need a pump, if you don't have power to the pump you have a relay, fuse or chafe in the wiring.
06-19-2019 01:38 AM
Zack Vogler
Help code P0231

Yes I have a 02 Ford f250 7.3. I was driving around with no problems. I stopped and got back in and turned it on and it was running rough, as I got closer home it was starting to lose power like it was running out of fuel,there is fuel in it, until it cut off. I pulled it home with my tractor and now it will just turn over and not cut on. If it does cut on it is for a very short time and it will lug down and die. I plugged it in and it showes P0231. Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome