Ford Powerstroke Diesel Forum - Reply to Topic
6.7 Problems Forum (2011-2016) 6.7 Problems Forum

Thread: Fluid Leak Under Dash Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-31-2019 08:15 AM
Mudrun08 I had my O-rings and turbo supply line changed at ford and when I picked it up I had a little fluid on floor mat from same line. Don't know why or what.
03-17-2019 09:23 AM
honemch Now the next question is who put the wrong coolant in the truck... should be orange.


Sent from my iPhone using Tapatalk
03-11-2019 08:03 PM
glacierF250 I’m thinking the coolant from the heater core may be the issue. The fluid has the consistency of coolant.
03-11-2019 06:56 PM
honemch Coolant leaking from the heater core?
03-11-2019 06:37 PM
glacierF250 Just an H&S w/ can tunes and an exhaust system
03-11-2019 06:35 PM
glacierF250 Just can’t figure why it would be leaking
03-11-2019 06:34 PM
powerstrokeshellback Any aftermarket stuff installed?
03-11-2019 06:33 PM
glacierF250 I think it traces back to the brake booster and power steering reservoir
03-11-2019 06:31 PM
powerstrokeshellback Mmmm lemon lime.

What's that go too?
03-11-2019 06:27 PM
glacierF250 It’s very similar to yellow Gatorade
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome