Ford Powerstroke Diesel Forum - Reply to Topic
Thread: Not normal Diesel Pedal issue?? help Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
03-17-2018 03:28 PM
greenskeeper
Quote:
Originally Posted by rpetty5555 View Post
Is it possible to bypass the IVS to verify that is the issue?
your truck should have separate harnesses, so yes you could in theory bypass the IVS. I believe it closes off idle, so if you start the truck and jump the 2 wire for the IVS closed everything should work normal.

Since both pedal assemblies aren't working, I'd look at the wiring path and harness connections for continuity.

I've honestly never had to mess with this, so take it for what it's worth.
03-17-2018 12:53 PM
rpetty5555 Is it possible to bypass the IVS to verify that is the issue?
03-17-2018 10:46 AM
rpetty5555 Thanks, I tried that ... I just hooked it up to Forscan and did not realize I could monitor with that APP...
It does show movement on accelator when pressed.. but there is no movement on either pedal from the IVS switch... how can I test the switch? And what are the odds both pedals have a bad switch?
Pedal shows 12.89 at idle up to 79 when fully pressed..
#19 fuse is also good to go
Any other items I can run in Forscan?

Quote=greenskeeper;15866826]I would clean your old throttle pedal assembly.

Without the ability to monitor, you're really throwing parts at it.

Autoenginuity would allow you to see the position of the IVS and TPS[/QUOTE]
03-17-2018 10:21 AM
greenskeeper I would clean your old throttle pedal assembly.

Without the ability to monitor, you're really throwing parts at it.

Autoenginuity would allow you to see the position of the IVS and TPS
03-17-2018 09:34 AM
rpetty5555 More details
Found this code as well,
Exhaust Back Pressure sensor circuit malfunction
As well as cruise control appears to be inop, not sure if that could be related in any way..
03-16-2018 05:11 PM
rpetty5555
Not normal Diesel Pedal issue?? help

Hey everyone, need some trouble shooting help...

Early 99 with 6spd

Just got done after 10 months of doing A full engine rebuild +40 pistons rebuild turbo, went through everything I could...

Fired her up the other day and she started after 30 seconds(what a relief) and sounds frigging awesome!!!

BUT, I went to step on Pedal and no response.. So off to the forums I went and everything pointed at either TPS or IVS, So I just purchased a Ford OEM pedal assembly thinking that would work.. Still doing exact thing. Press pedal, SES light comes on, release SES goes off. SES code shows p0221

I ran the KOER test and the truck REVS up, so it obviously has the ability to Rev, all fuses and wires seem to not be in bad shape...

Any help on where to go next? Im not that great with a OHM meter but willing to learn..

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome