Ford Powerstroke Diesel Forum - Reply to Topic
Thread: What did you do to your 7.3 Today? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
Today 07:04 AM
PlumberJoe I have a 2003 E350 that I’m trying to sell. If interested, I can discuss further details.
Today 05:13 AM
guitarnut
Quote:
Originally Posted by forthehalibut View Post
Truck check engine light came on and stayed on for a few days. Turns out that the connection to the valve cover was bad and the wire to #4 injector broke causing it to misfire. Shop that put in the new engine just went ahead and replaced the outside plug and truck's running like a top again. I was surprised when they rang the doorbell and dropped the truck and key off at my home.
As much as you spent they should!

Sent from my Nexus 6P using Tapatalk
Yesterday 07:38 PM
forthehalibut Truck check engine light came on and stayed on for a few days. Turns out that the connection to the valve cover was bad and the wire to #4 injector broke causing it to misfire. Shop that put in the new engine just went ahead and replaced the outside plug and truck's running like a top again. I was surprised when they rang the doorbell and dropped the truck and key off at my home.
Yesterday 07:04 PM
Bri_Man57
Quote:
Originally Posted by ToyMan View Post
Not sure how to keep it center over the existing holes and the machine looks too big. Unless I am looking at the wrong rotabroach listing.



Thanks for the idea.
It's like a spot weld remover. Would you have a center mark or no?

Sent from my SM-N920T using Tapatalk
Yesterday 05:57 PM
ToyMan
Quote:
Originally Posted by guitarnut View Post
Damn dude. That is some serious fabrication. You should apply for a job on Texas metal.

Sent from my Nexus 6P using Tapatalk

Thanks, so far just fitting stock 2008 brackets to my 99 frame.
Yesterday 05:56 PM
ToyMan
Quote:
Originally Posted by Bri_Man57 View Post
You could try a rotabroach, might make quick work of the 5/8 holes

Sent from my SM-N920T using Tapatalk
Not sure how to keep it center over the existing holes and the machine looks too big. Unless I am looking at the wrong rotabroach listing.

Thanks for the idea.
Yesterday 12:52 PM
Bri_Man57 You could try a rotabroach, might make quick work of the 5/8 holes

Sent from my SM-N920T using Tapatalk
Yesterday 11:02 AM
guitarnut
Quote:
Originally Posted by ToyMan View Post
More pictures for above post.
Damn dude. That is some serious fabrication. You should apply for a job on Texas metal.

Sent from my Nexus 6P using Tapatalk
Yesterday 07:10 AM
ToyMan More pictures for above post.
Yesterday 07:07 AM
ToyMan Got closer to fitting the 4WD front end into the truck.

Fabtech 2wd 6" fit out, 2008 passenger side radius arm suspension mount in with 5/8" grade 8 bolts. Rivets in this part were that big.

Drilling in the chassis with this big of a bit is not fun. I used a step drill to start, then finished with a 5/8" bit.

I have one new hole to drill and two holes in the frame to grind out to match bracket.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome