Ford Powerstroke Diesel Forum - Reply to Topic
Thread: Check engine light and flashing wait to start light Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-18-2009 01:39 PM
deerhunter338 I had a very similar problem with the wait to start and the check engine flashing. I checked all connections and had no luck. Finally I just pushed down on the relays under the hood on driver side. I had my wife turn the key and it started like normal. One of the relays just had a bad connection in my case.
10-10-2005 08:18 PM
WV Hillbilly 97 superduty I thought it was the glow plugs too & had them changed. Problem is the heating element in the fuel water seperator has died. If I don't plug in and it gets into the 50's I have to cycle the glow plugs 5 times b4 it starts. It idles very rough and puts out plenty of smoke for a few minutes and then it smoothes out as the engine warms.
PS. The colder it gets the harder it is to start if you get it started.

I am replacing mine before we get snow in December.

PSS Watch your water pump they start leaking around 120-140k
10-08-2005 04:49 PM
wesjones right about the separator, you might want to drain it off a little, although fuel water separator issues are supposed to illuminate the water in fuel light...as for the wait to start, the glowpugs may be bad causing the light to come on, but the glowplugs aren't causing the engine failure...
10-07-2005 05:51 PM
WV Hillbilly 97 superduty I have a 97 F250 and I think I know what it is. The resevouir where your fuel/water seperator installs is also a prewarmer for the fuel. If it only does this on cool days and only after it has thoroughly cooled down I would say this is it. Try and plug it in to electric and see if it start ok the next morning if it does this is it.
My truck started that last year and the mileage is similar. I held off replacing it since its over 200.00 plus labor.
08-19-2005 01:03 PM
Kshow nothing, completely stock.
08-19-2005 08:47 AM
Andy That is very odd. Do you have some kind of a power programmer that you use on your truck that also does diagnostics? The Edge Evolution, Superchips Microtuner, and Diablosport Predator all do diagnostics.

Lem
08-19-2005 06:49 AM
Kshow
Check engine light and flashing wait to start light

97 7.3L PS, tried to start this morning, check engine light and wait to start light flashed continuously ran like hitting on only half the cylinders then stalled. This has never happened before. GP relay has been replaced and i know glow plugs need replaced. Have had no starting problems this summer. Talked to garage they had no idea. Did say the flashing wait to start light was very odd. Came home from garage tried to start truck again same thing, then smoothed out it ran fine. Any ideas? 120K on truck.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome