Ford Powerstroke Diesel Forum - View Profile: Bramstroker

Bramstroker Bramstroker is offline

Compression Ignition Addict

  About Me

  • About Bramstroker
    State/Province
    Arizona
    Interests
    Ham radio, motorcycles, trucks, building stuff
    Exact Location
    Prescott valley AZ
    Occupation
    Dad
    Ride
    97 f250 97 k1500 z71
    Engine
    7.3 DI factory turbocharged
    Cab Configuration
    Extended Cab Long Box
    Drivetrain
    Single Rear Wheel 4X4
    Tranny type
    5 Speed Manual
    Tires
    Mudders
    Horsepower
    0.0
    1/8 Mile ET
    0.000
    1/8 Mile MPH
    0.00
    1/4 Mile ET
    0.000
    1/4 Mile MPH
    0.00
  • Signature
    97 7.3 psd zf5 4x4 lifted on 35s
    97 gmc sierra z71 5.7 vortec extra cab on 33s

  Statistics

Total Posts
Total Thanks
General Information
  • Last Activity: 02-06-2020 10:18 PM
  • Join Date: 04-08-2018
  • Referrals: 0

  Mentions

No results to display...

  Quotes

01-10-2020
02:18 PM - Bramstroker quoted Patrick Feeley in post Got stuck getting firewood, cranks no start, no tach, new sensor
Without seeing the actual PCM label...
11:37 AM - Bramstroker quoted Patrick Feeley in post Got stuck getting firewood, cranks no start, no tach, new sensor
$80 for injectors seems like a good...
10:52 AM - Bramstroker quoted JustinOOO9 in post Got stuck getting firewood, cranks no start, no tach, new sensor
Do not rebuild them yourself. M...
10:45 AM - JustinOOO9 quoted Bramstroker in post Got stuck getting firewood, cranks no start, no tach, new sensor
how hard are they to rebuild? ...
10:27 AM - Bramstroker quoted White95f250 in post Got stuck getting firewood, cranks no start, no tach, new sensor
95 was slightly different, mine ...
08:20 AM - Bramstroker quoted White95f250 in post Got stuck getting firewood, cranks no start, no tach, new sensor
Unless it is a Cali model then n...
08:14 AM - Bramstroker quoted Patrick Feeley in post Got stuck getting firewood, cranks no start, no tach, new sensor
Not really except for the Californi...
01-08-2020
05:10 PM - Bramstroker quoted JustinOOO9 in post P0603
99.9% its the KAM keep alive me...
12-30-2019
02:34 PM - Bramstroker quoted White95f250 in post Temp gauge and pcm temp reads way too low.
O-rings should work fine. OBS ...
01:21 PM - Bramstroker quoted White95f250 in post Temp gauge and pcm temp reads way too low.
The 95 is a little bit different...
12:04 PM - Bramstroker quoted White95f250 in post Temp gauge and pcm temp reads way too low.
As for the oil temperature there...
09:29 AM - Bramstroker quoted White95f250 in post Temp gauge and pcm temp reads way too low.
The temperature on the PCM is th...
09:27 AM - Bramstroker quoted PDR60 in post Temp gauge and pcm temp reads way too low.
If you have the harness pu...
12-29-2019
05:11 PM - Bramstroker quoted Hydro in post Temp gauge and pcm temp reads way too low.
Since you have the harness...
04:22 PM - Bramstroker quoted Hydro in post Temp gauge and pcm temp reads way too low.
Some oil in the turbo inle...
01:36 PM - Bramstroker quoted Hydro in post Temp gauge and pcm temp reads way too low.
Coolant temp sensor is loc...
12-28-2019
07:08 PM - Bramstroker quoted SystemicInfluencer in post Turbo Charger Wires
Quick update on this. The turbo is ...
12-27-2019
12:30 PM - Bramstroker quoted White95f250 in post Got stuck getting firewood, cranks no start, no tach, new sensor
Valve cover gaskets and UVCH are...
12-26-2019
10:06 PM - Bramstroker quoted White95f250 in post Got stuck getting firewood, cranks no start, no tach, new sensor
No problem. Thanks for the updat...
10:27 AM - Bramstroker quoted White95f250 in post Got stuck getting firewood, cranks no start, no tach, new sensor
Could try calling Beans Diesel a...

  Feedback Score

iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
Submit Feedback
  Past
Month
Past
6 Months
Past
12 Months
Positive Positive 0 0 0
Neutral Neutral 0 0 0
Negative Negative 0 0 0
 
For the best viewing experience please update your browser to Google Chrome