Hello - Ford Powerstroke Diesel Forum
Introductions This is the place that you introduce yourself

 2Likes
  • 1 Post By bebop4u
  • 1 Post By 5J's
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 09-17-2019, 08:56 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hello

Hey guys, new to the group, I have a couple F-3550s but my personal one is a 2003 4 door dually with the Lariat package, 7.3 automatic 625,000 miles on original tranny, bought it new. Great truck but having some electrical issues with it now. When I turn on my overhead with the push button in the ceiling the light comes on then immediately goes out and my windows wont work and radio wont work. When I turn it back off the windows and radio will come back on after a while. I believe it is tied into the delayed entry but cant seem to find any info on what is causing it, short, bad ground, etc. Any suggestions. Thanks
SyntheticAlex likes this.
bebop4u is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 09-17-2019, 10:24 AM
Powerstroke.org Fanatic
 
Join Date: Apr 2019
Posts: 129
Thanks: 1
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
Feedback Score: 0 reviews
I've got the same issue in my work truck. 2002 SCLB 2wd 7.3 4r100 311K miles. The company isn't interested in spending any time on this old thing so I just live with it for now. It took me some time to get used to. I can't pattern the issue so I'm not sure where to look but, I'm leaning in the same direction as you.

Sent from my LG-LS993 using Tapatalk
SyntheticAlex likes this.
5J's is offline  
post #3 of 4 Old 09-17-2019, 12:48 PM
N.S.D.Q.


 
HeavyAssault's Avatar
 
Join Date: Oct 2007
Location: Middle VA
Posts: 8,153
Thanks: 59
Thanked 394 Times in 379 Posts
Mentioned: 94 Post(s)
Quoted: 822 Post(s)
Feedback Score: 3 reviews
Make sure to visit the rest of the forum sections. There are areas to address your specific questions. Welcome!!



Officially The Biggest Midget In The Game

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HeavyAssault is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 09-17-2019, 07:07 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Good to hear from you 5j's, after searching a bunch of different forums and websites I decided to take the steering column apart, low and behold one of the small wires going to the overdrive button was bare and shorting out, fixed that and so far so good except for the radio not coming on. If I hit the dash right above the instrument cluster it well come on. According to what I have read the whole issue is with the instrument cluster being bad. Apparently there is some type of relay for the acc. delay built into the cluster itself and these go bad with age. The only fix is to have it sent off and be repaired or find one from a like vehicle and replace but then you have to get odometer redone which should not be a big issue. If I am not mistaken ONLY year models 2002 an 2003 with the 7.3 will work. Also a lot of people were telling me the gen module was bad, our year vehicle does not have a gen module, but instead have a VSM I am assuming Vehicle Security Module. On my 03 it is behind the big brace behind the radio on the inside firewall right under the windshield, a bugger to get to. Try hitting the dash and see if that works, I know it sounds kinda redneckish but if it helps to figure out what is wrong so be it, lol.
bebop4u is offline  
Sponsored Links
Advertisement
 
Reply

Tags
delay , electrical issues , electrical problem , wiring

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome