Post injector job madness! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 10-14-2019, 11:15 AM Thread Starter
Powerstroke.org Rookie
 
Twglace's Avatar
 
Join Date: Oct 2019
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Post injector job madness!

Hey all I have a 99.5 7.3 194k got it about 3 months ago for a really good deal (knowing I had to replace the injectors) so I decided to pull them and send them to SoCal diesel to be rebuilt put them in and the truck ran like a dream! So much more power quiet and smooth! Now Im about 500 miles post and my truck is now blowing insane white clouds when starting up as well as rough idle and very slight blue smoke if Im sitting at a light when I first punch the fuel it seems off but than it it full power runs great until I go back down to idle. The white smoke happens even if I let the truck sit for only 10-20 mins. Im worried because i pulled my fuel bowl due to a leak and rebuilt all the seals and I noticed a crap load of rust like bits on the bottom..... so now Im thinking I have fuel Tank delamination? I have already ordered a new tank and screens. My question is am I going down the right path? It really seems like my pickup screens might be clogged ? I have checked my HPOP and it’s full of oil and my fuel bowl is filling

*update I wrote this yesterday and today driving it has lost almost all power and shakes like crazy*


Any input of be greatly appreciated.
Twglace is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 10-14-2019, 11:16 AM Thread Starter
Powerstroke.org Rookie
 
Twglace's Avatar
 
Join Date: Oct 2019
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
I have checked my fuel filter and it looks fine as well as air filter and all intercooler boots. No leaks could it possibly be ICP or IDR?
Twglace is offline  
post #3 of 7 Old 10-14-2019, 12:37 PM Thread Starter
Powerstroke.org Rookie
 
Twglace's Avatar
 
Join Date: Oct 2019
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Update I drained the fuel bowl and filled with injector cleaner started up with white smoke still but ran with full power.... so does that point to clogged screens in the tank? I’m lost
Twglace is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 10-14-2019, 03:16 PM
Powerstroke.org Rookie
 
Join Date: Aug 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My 97 is doin the same thing! I removed and bought new brushes to clean the cups better and now driving a bit at night to eliminate air.
I drove 700 and then kapow A hearty Hi Oh Silver! Had her up to 100mph just trying to get anything to be wrong!
I am going to do another compression test soon. I feel yer pain. I got a new IDM as well and I keep having a skip that smooths out and comes back. Throwing P1298 despite an almost loud buzz test and special Michelob moments of super duper smooth idle?
HELP PLEASE ANYONE BOO HOO
Who should I see about a Reman?
AnarchoilBurner73 is offline  
post #5 of 7 Old 10-14-2019, 09:16 PM
Compression Ignition Addict
 
Join Date: May 2018
Posts: 172
Thanks: 0
Thanked 6 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 39 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Twglace View Post
Update I drained the fuel bowl and filled with injector cleaner started up with white smoke still but ran with full power.... so does that point to clogged screens in the tank? Iím lost
You need to drop the tank and check the pickup. There is a black funnel-shaped pickup that becomes brittle and crumbles and gets sucked into the pickup tube. It will seem like the truck is running out of fuel.

Tom

2014 XLT Premium CC Dually 2WD, Remote Start Added, Diesel Site Dual Filters, Rudy's Cold Air Pipe, Infotainment Radio Swap + Rear Camera Added

2002 XLT CC Dually 2WD, 6 Spd, True Workhorse that kept going.

1999 F250 Lariat CC LB SRW 2 WD, Automatic. Just didn't perform towing.
tomshep is offline  
post #6 of 7 Old 10-15-2019, 06:41 AM Thread Starter
Powerstroke.org Rookie
 
Twglace's Avatar
 
Join Date: Oct 2019
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
That’s exactly what I’m doing ! Glad I’m on the right track I went ahead and ordered a new tank/ screens and got a really good deal on a new pump. My only concern is the white smoke at start up that would imply there is fuel in the cylinder that’s being dumped correct?
Twglace is offline  
post #7 of 7 Old 10-15-2019, 09:30 AM
Powerstroke.org Rookie
 
Join Date: Aug 2019
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Twglace View Post
That’s exactly what I’m doing ! Glad I’m on the right track I went ahead and ordered a new tank/ screens

IMHO if that were my assembly gone wrong a DIY Hutch and Harpoon? just need a couple of 5/16id comp couplings and about 2 foot of 5/16 id copper or stainless. Ditch the useless drop the tank to service screens? Diesel Fuel has steadily become of less and less quality to the point Bio is competitively priced and far cleaner.
Anyhow save the chedda fir a fass pump filter or just filter. Raycor makes super affordable super low micron filters for Marine or ? use. I use their 1000hp Heated Pump and 5 mic to 2 mic filters. a case of filters was $40 ea.


and got a really good deal on a new pump. My only concern is the white smoke at startup that would imply there is fuel in the cylinder that’s being dumped correct?
yup and if the compression leak makes ut to the 2nd Oring up then you will stick the plunger and the intensified but not atomized fuel will quickly burn a hole through a piston like a plasma cutter!

That's why I went back and resealed and cleaned the cups like perfect with new brushes... new brushes were the trick.
I am still pumping smoke but meh getting better? Have a skip at low speed, smoke at more than quarter throttle except when I jump on the freeway?
Then idle like I have an UVCH problem when I am sitting at the light on the ramp
AnarchoilBurner73 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome