PCM or bad Hydra chip? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 06-16-2019, 07:17 PM Thread Starter
Premium Member
 
jonathanh96's Avatar
 
Join Date: Dec 2017
Location: Riverside
Posts: 114
Thanks: 0
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
Feedback Score: 0 reviews
PCM or bad Hydra chip?

So I had gotten an extension cable for my Hydra chip and I installed it late at night (nothing good ever happens at night working on things) after work. When I put it back in I didn't realize how tight the cable was when I slid the USB cable into it, it had broke the connector off.

I was getting an error on my PC saying the USB has a short in it when I tried to plug it in it didn't work.

I pulled it back apart and noticed it, after that issue I tried to save the chip by making some very quick solder joints (which surprised me that I didn't melt the board as they used solder paste to assemble it)

Now when you plug it into the USB the Hydra chip display lights up, signals "PHP" & displays all the tunes and all the information. When it's plugged in to the truck's PCM the hydra chip display does not light up and the tunes do not work however if plugged into the truck & laptop in the hydraflash program it does recognize if the key is in the on or off position.

I'm trying to find out if potentially I damaged the PCM or if I damaged the chip. Unfortunately I don't have a diagram on the chip or any information on how the traces are ran.

'02 F-250 7.3
180/80% Stage 2 Full Force Injectors
S&B Intake
Hydra running Gearhead Tunes
5" Straight Pipe
Bellowed Up-Pipes
Bilstein 5160 Resi's
Rough Country Dual Steering Stabilizer
etc, etc
jonathanh96 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 06-16-2019, 07:31 PM
Compression Ignition Addict
 
hansel's Avatar
 
Join Date: Dec 2006
Location: Flowery Branch, GA
Posts: 3,017
Thanks: 54
Thanked 130 Times in 122 Posts
Mentioned: 5 Post(s)
Quoted: 376 Post(s)
Feedback Score: 0 reviews
OOOPPPSSSS

Sounds like the chip is toast

2001 7.3L CCSRW 4X4
2003 7.3L CCDRW
S&B intake, 4" Flo-Pro Exhaust
ISSPRO EGT/Transmission. Edge SCT2
PHP Hydra chip's
2015 Heartland Prowler
hansel is offline  
post #3 of 4 Old 06-16-2019, 07:48 PM Thread Starter
Premium Member
 
jonathanh96's Avatar
 
Join Date: Dec 2017
Location: Riverside
Posts: 114
Thanks: 0
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by hansel View Post
OOOPPPSSSS

Sounds like the chip is toast<img src="https://www.powerstroke.org/forum/images/Powerstroke_org_2015/smilies/tango_face_crying.png" border="0" alt="" title="Crying" class="inlineimg" /><img src="https://www.powerstroke.org/forum/images/Powerstroke_org_2015/smilies/tango_face_crying.png" border="0" alt="" title="Crying" class="inlineimg" />
Unfortunately! I have a gut feeling it's the chip as I'm not experiencing any other issues other than rough idle (I have single shots) however it's still reading data from the vehicle(key position) and it can still read the tunes so I'm not sure if I just broke one component and if so if there is any information on a diagnosis. I feel very confident if I have some information I can repair the chip myself and save some money, I'm fairly confident with a soldering iron. Been around it my entire life working on RC, designing simple circuitry & repairing ham radios

'02 F-250 7.3
180/80% Stage 2 Full Force Injectors
S&B Intake
Hydra running Gearhead Tunes
5" Straight Pipe
Bellowed Up-Pipes
Bilstein 5160 Resi's
Rough Country Dual Steering Stabilizer
etc, etc
jonathanh96 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 Old 06-21-2019, 02:18 AM Thread Starter
Premium Member
 
jonathanh96's Avatar
 
Join Date: Dec 2017
Location: Riverside
Posts: 114
Thanks: 0
Thanked 6 Times in 6 Posts
Mentioned: 0 Post(s)
Quoted: 18 Post(s)
Feedback Score: 0 reviews
Since everyone always wants to know the outcome of a thread 2 years later after it's fixed it was the chip. Got a replacement in & it runs like it's supposed to.

'02 F-250 7.3
180/80% Stage 2 Full Force Injectors
S&B Intake
Hydra running Gearhead Tunes
5" Straight Pipe
Bellowed Up-Pipes
Bilstein 5160 Resi's
Rough Country Dual Steering Stabilizer
etc, etc
jonathanh96 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome