Low oil pressure 100 miles after rebuild - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-07-2018, 02:22 PM Thread Starter
Member
 
Join Date: Mar 2017
Location: Gadsten AL
Posts: 44
Thanks: 6
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Low oil pressure 100 miles after rebuild

Hey guys, need some ideas...
I have a early 99 with 275k miles, little over 100 miles since I did a full rebuild. ..machine shop, new lpop, rebuilt injectors +40pistona new everything.. etc....
Fired right up and has been running great minus the turbo rear seal/housing that i just fixed..

At first the oil Guage would read normal at idle and drop when accelerated. Now, no oil pressure at idle but after 1500rpm it comes up.. I did put it on a manual Guage via top of hpop and was getting around 5-7psi at idle and 20+ @ 1500rpm..
I drained and inspected oil, minimal metal as to be expected after rebuild, scoped oil pan and could not find anything in there but could not see pickup screen/tube. Took it to a very reputable diesel shop and they could not figure it out... any ideas on where to go from here, I really do not want to pull this engine again.. thanks in advance!!
rpetty5555 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-08-2018, 05:08 AM
Compression Ignition Addict
 
Join Date: Oct 2015
Posts: 367
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 2 Post(s)
Quoted: 46 Post(s)
Feedback Score: 0 reviews
Have you checked the oil pressure relief valve?

97 F350 XL std cab, zf5, srw (converted), 4wd, 3.55s, stock wheels/tires & rebuilt 9.18
2 Donaldsons, 3" dp, ACs, T500, HV LPOP, Hydra w/PHP, DIY 60 gl tank w/6 gl sump, eFuel/Cat filters, Aeromotive RR, Auber instruments, 140v IDM, KC 300X 63/70/84, boost fooler, RiffRaff bellowed up pipes, 6.0 IC, 3" plenums w/RiffRaff inserts & SB 425HD
MeTo is offline  
post #3 of 3 Old 09-08-2018, 05:28 AM Thread Starter
Member
 
Join Date: Mar 2017
Location: Gadsten AL
Posts: 44
Thanks: 6
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by MeTo View Post
Have you checked the oil pressure relief valve?
No, I have read several other forums and that seems to be a issue. But when I just changed my oil I realized that the oil cooler assembly must come out to do that. .. I will check that this weekend...
Thank you..
rpetty5555 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome