No Boost Until High RPM - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 04-28-2018, 07:03 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2014
Posts: 263
Thanks: 16
Thanked 17 Times in 17 Posts
Mentioned: 0 Post(s)
Quoted: 19 Post(s)
Feedback Score: 0 reviews
No Boost Until High RPM

Like the title says, I'm building 0psi until maybe 2500rpm, then only a couple psi. If I lug it in 4th, it will build 25psi or so before I let off the throttle. I just rebuilt the turbo with a billet wheel, bearings, etc and it's sitting on a deleted pedestal with all new o rings. I have a turbomaster wastegate on there which hasn't been adjusted since I can't get a good reading. I can hear the turbo spooling at all rpms, however it is much quieter than I thought it should be considering the intake, 5" exhaust, removed foil, and billet wheel.

Any ideas?

2000 ECLB 4x4 7.3L PSD - Converted from a beat up XL farm truck and frame off restored thanks to New England road salt
Cosmetic: 05 Harley front end, 11 tailgate, black sport full power interior, 05 dash with aux switches and brake controller
Performance: AFE intake, SPX billet compressor wheel, Turbomaster wastegate, blank pedestal & exhaust housing, MBRP 5" exhaust, PHP Hydra, gauges and CTS2
Audio: Sony XAV-AX5000, JBL Club speakers, fully sound deadened

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Lt.Dan is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 04-28-2018, 07:13 AM
Premium Member
 
DieselDC's Avatar
 
Join Date: Sep 2016
Posts: 2,388
Thanks: 44
Thanked 183 Times in 181 Posts
Mentioned: 18 Post(s)
Quoted: 682 Post(s)
Feedback Score: 0 reviews
Well your wheel isnít slipping since youíre building boost in 4th. Whatís your hot side size? .84, 1.0 etc?

You gotta adjust that wastegate.

Other thing I can only think of is a boost leak


ďDonít overthink something simple people... ..:sigh:..Ē
DieselDC is offline  
post #3 of 3 Old 04-28-2018, 09:45 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2014
Posts: 263
Thanks: 16
Thanked 17 Times in 17 Posts
Mentioned: 0 Post(s)
Quoted: 19 Post(s)
Feedback Score: 0 reviews
It's stock off a van turbo, which I believe is .84.

The wastegate is set at the manufacturer recommended "safe" setting for those without boost gauges. I should have mentioned I'm heading boost through the MAP sensor (CTS2) and through a mechanical boost gauge tapped into the MAP line before an overboost regulator.

A boost leak was my first thought because I didn't see it ever building boost, but it's curious that it holds that 25lbs under certain conditions. I'm kinda thinking I left a rag in one of the intercooler passages.

Currently, the truck is dead in a parking lot somewhere so I want to investigate when I get it home. Just seeing if others had something I was overlooking. Thanks!

2000 ECLB 4x4 7.3L PSD - Converted from a beat up XL farm truck and frame off restored thanks to New England road salt
Cosmetic: 05 Harley front end, 11 tailgate, black sport full power interior, 05 dash with aux switches and brake controller
Performance: AFE intake, SPX billet compressor wheel, Turbomaster wastegate, blank pedestal & exhaust housing, MBRP 5" exhaust, PHP Hydra, gauges and CTS2
Audio: Sony XAV-AX5000, JBL Club speakers, fully sound deadened

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Lt.Dan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome