Intermittent Turbo Piston Seal Leak - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 01-18-2020, 10:38 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2016
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
Intermittent Turbo Piston Seal Leak

Curious if anyone has dealt with a turbo seal leaking intermittently, on either exhaust or comp side?

Ie truck smokes when cold, but stops when warm.
newobs is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-19-2020, 05:47 AM
Compression Ignition Addict
 
7.3_TurboDiesel's Avatar
 
Join Date: Aug 2017
Posts: 511
Thanks: 0
Thanked 32 Times in 32 Posts
Mentioned: 2 Post(s)
Quoted: 132 Post(s)
Feedback Score: 0 reviews
Sounds like an injector to me. Does it start ok cold without being plugged in?


Sent from my iPhone using Tapatalk
7.3_TurboDiesel is offline  
post #3 of 7 Old 01-19-2020, 11:45 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2016
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
Yeah other than smoke. Issue was the same before so I also figured injectors. But with only like 12-15k on the 238/80's, injectors were pulled have been flowed by FFD and 1 nozzle replaced. 8 new Ford/Beru GP's, and new Western GPR were installed as well.

Wondering if perhaps this is just related to tuning, on the larger injectors? I cannot go to a stock tune, because the injectors are singles on a split pcm.
newobs is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 01-21-2020, 01:10 PM
Compression Ignition Addict
 
7.3_TurboDiesel's Avatar
 
Join Date: Aug 2017
Posts: 511
Thanks: 0
Thanked 32 Times in 32 Posts
Mentioned: 2 Post(s)
Quoted: 132 Post(s)
Feedback Score: 0 reviews
Who’s tunes do you have?


Sent from my iPhone using Tapatalk
7.3_TurboDiesel is offline  
post #5 of 7 Old 01-25-2020, 03:18 AM
Member
 
AgInternational's Avatar
 
Join Date: Jun 2017
Posts: 43
Thanks: 6
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Feedback Score: 0 reviews
Sounds similar to what I've got, the smoke part. My injectors are stock sized though and have been in for 20k now.

Sent from my moto x4 using Tapatalk

2000 F350 7.3L CC LB 6 speed manual 4x4
391,000 miles and counting
Always fixing it...

Last edited by AgInternational; 01-25-2020 at 03:24 AM.
AgInternational is offline  
post #6 of 7 Old 01-25-2020, 11:10 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2016
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
Swamps Tunes, 6 or 7 years.


If I didn't have single shots, I would remove the chip to see if it is a tuning issue.

Anyone know how I can run singles with stock tuning, on a split pcm truck?

I've considered it to be a tuning issue, as I have heard others say. I've seen videos online, of trucks with these size injectors running clean, so I know it can be done. Just a matter of who's tunes it is I guess.

Turbo does have what feels to be a ton of side to side play, not too much in and out. No contact with housing. It does not feel normal whatsoever, but then I have heard that these t4's may have wider bearing clearances, so as long as it doesn't touch I am good.

The truck did this same thing before I sent the injectors to be checked by FFD, and replaced with new orings. I'm considering sending injectors to another place to see if they show the same.

Before I do that I am gonna go through and check all injectors for level, oil flow, and hot torque everything.
newobs is offline  
post #7 of 7 Old Today, 05:48 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2016
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Feedback Score: 0 reviews
Bump.

Pulled turbo didn't find oil in exhaust side.

Hot torqued injectors at 120+.

Any other ideas guys?
newobs is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome