2001 7.3 stalling new ford cps no CEL - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 39 Old 09-04-2018, 07:59 AM Thread Starter
Compression Ignition Addict
 
Join Date: Apr 2016
Posts: 176
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Feedback Score: 0 reviews
2001 7.3 stalling new ford cps no CEL

Im having a problem with my truck stalling at idle after its warmed up for a bit, it starts right up afterwards and doesnt throw a CEL code when it stalls. In the morning it does sometimes have CEL light on but when i go to read it with the torque pro app it goes away. Before it stalls the rpms will usually flutter a little bit like go up then drop to about 500 so not sure if its the tps or something. I just replaced the crank sensor with a ford oem one (grey one) although i found out afterwards the black ones can work better, also changed the fuel filter. Every time i try to scan it the code goes away so does anyone have any ideas? any help is appreciated. Thank you.
nick1993 is offline  
Sponsored Links
Advertisement
 
post #2 of 39 Old 09-04-2018, 08:07 AM
DieselDC
 
DieselDC's Avatar
 
Join Date: Sep 2016
Posts: 2,358
Thanks: 44
Thanked 183 Times in 181 Posts
Mentioned: 18 Post(s)
Quoted: 677 Post(s)
Feedback Score: 0 reviews
Injectors worn


—————signature—————
~Don’t overthink something simple~
...:uptight people suck:...
DieselDC is offline  
post #3 of 39 Old 09-04-2018, 08:09 AM
Compression Ignition Addict
 
White_Buffalo7.3's Avatar
 
Join Date: Aug 2017
Location: Reinholds Pa
Posts: 704
Thanks: 22
Thanked 53 Times in 52 Posts
Mentioned: 5 Post(s)
Quoted: 170 Post(s)
Garage
Feedback Score: 0 reviews
Harness under valve cover

180/30s,KC38R, CNC Fab Stg 2 HPOP, Sump, Walbro, Donaldson 6637, Leveled, 4'' straight to 7'' tip, 08 mirrors, 6.0 front end ect...
White_Buffalo7.3 is offline  
Sponsored Links
Advertisement
 
post #4 of 39 Old 09-04-2018, 08:47 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 7,899
Thanks: 9
Thanked 401 Times in 389 Posts
Mentioned: 27 Post(s)
Quoted: 407 Post(s)
Feedback Score: 3 reviews
Make sure your Torque App is properly configured (you don't use it out-of-the box)

Read through this about your app -> https://www.powerstroke.org/forum/99-...sis-cheap.html

It makes No Sense to me to be making wild guesses when you see, even a "disappearing", code that can direct you to a problem
NoRalPh is offline  
post #5 of 39 Old 09-04-2018, 10:09 AM Thread Starter
Compression Ignition Addict
 
Join Date: Apr 2016
Posts: 176
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Feedback Score: 0 reviews
ok, i just set it up to read ipr and icp readings, im hoping its something with one of those sensors
nick1993 is offline  
post #6 of 39 Old 09-04-2018, 10:12 AM
Compression Ignition Addict
 
White_Buffalo7.3's Avatar
 
Join Date: Aug 2017
Location: Reinholds Pa
Posts: 704
Thanks: 22
Thanked 53 Times in 52 Posts
Mentioned: 5 Post(s)
Quoted: 170 Post(s)
Garage
Feedback Score: 0 reviews
How many miles you got?

180/30s,KC38R, CNC Fab Stg 2 HPOP, Sump, Walbro, Donaldson 6637, Leveled, 4'' straight to 7'' tip, 08 mirrors, 6.0 front end ect...
White_Buffalo7.3 is offline  
post #7 of 39 Old 09-04-2018, 10:22 AM Thread Starter
Compression Ignition Addict
 
Join Date: Apr 2016
Posts: 176
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by White_Buffalo7.3 View Post
How many miles you got?
its got 263000
nick1993 is offline  
post #8 of 39 Old 09-04-2018, 10:23 AM Thread Starter
Compression Ignition Addict
 
Join Date: Apr 2016
Posts: 176
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Feedback Score: 0 reviews
not sure if injectors have already been replaced or not, ICP doesnt have any oil in it when i unplugged it to check
nick1993 is offline  
post #9 of 39 Old 09-04-2018, 11:23 AM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 7,899
Thanks: 9
Thanked 401 Times in 389 Posts
Mentioned: 27 Post(s)
Quoted: 407 Post(s)
Feedback Score: 3 reviews
Soooo, what are your #'s (IPR/ICP) before/after it starts to "flutter" on you, And,,, what were the codes you found?
NoRalPh is offline  
post #10 of 39 Old 09-04-2018, 11:26 AM Thread Starter
Compression Ignition Addict
 
Join Date: Apr 2016
Posts: 176
Thanks: 0
Thanked 7 Times in 7 Posts
Mentioned: 0 Post(s)
Quoted: 23 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by NoRalPh View Post
Soooo, what are your #'s (IPR/ICP) before/after it starts to "flutter" on you, And,,, what were the codes you found?
I just set it up a few minutes ago so ill read it once i get done work, but it won't read the codes, it just scans it and the code clears. The scanner does work because i used it on my fathers 7.3 to pull a code so not sure why it dissappears when i read it, ive read some people have said the grey cps can cause some trouble and to get the blue one from international, im hoping to get somewhere looking at the ipr and icp numbers tongiht
nick1993 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome