95 Ford Power Stroke Heads Are OFF - Page 4 - Ford Powerstroke Diesel Forum
 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 37 Old 12-21-2017, 06:30 PM
Compression Ignition Addict
 
Join Date: Mar 2011
Location: Tx
Posts: 3,729
Thanks: 6
Thanked 283 Times in 281 Posts
Mentioned: 12 Post(s)
Quoted: 307 Post(s)
Feedback Score: 0 reviews
HPOP pressure is extremely low and IPR is demanding pressure.

So either you have an injector O-ring leak or the HPOP is on its way out or faulty IPR. Make sure it is the correct IPR with the edge filter for the 95
White95f250 is offline  
Sponsored Links
Advertisement
 
post #32 of 37 Old 12-21-2017, 06:38 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2017
Posts: 27
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Can you tell me more about the edge filter. Would it be more simple to just swap the HPOP out, the replacement info on the valve cover listed it as a 96 mine was a 95. I did use my injectors and replace the injector o-rings my luck I will get to do it again.
post #33 of 37 Old 12-21-2017, 06:59 PM
Compression Ignition Addict
 
Join Date: Mar 2011
Location: Tx
Posts: 3,729
Thanks: 6
Thanked 283 Times in 281 Posts
Mentioned: 12 Post(s)
Quoted: 307 Post(s)
Feedback Score: 0 reviews
Edge filter is on the end of the IPR on a 95. For 96-97 it was moved to the inside of the HPOP. I have heard of using a 96-97 HPOP with a 95 IPR will cause issues and vice versa. I do forget the specifics but I am sure others can explain more, my brain is worn out for the day.


@madpogue @[email protected] @SuperchargedPSD
White95f250 is offline  
Sponsored Links
Advertisement
 
post #34 of 37 Old 12-21-2017, 07:04 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2017
Posts: 27
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I understand... Looks like I am gonna get a good education on this one...
post #35 of 37 Old 12-21-2017, 07:18 PM

 
Corey@CNCFAB's Avatar
 
Join Date: Apr 2010
Location: Defiance, OH
Posts: 12,598
Thanks: 1,240
Thanked 892 Times in 824 Posts
Mentioned: 1198 Post(s)
Quoted: 1431 Post(s)
Feedback Score: 4 reviews
IPR's are now all the same for all years of 7.3's, as is the gasket for the face of the pump.

www.cncfab.us

[SIZE="3"]For all your ford powerstroke needs. If you dont see what you are looking for on the website, please use the contact page and shoot us a message or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Part numbers will help alot too if they are not on our site.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
post #36 of 37 Old 12-22-2017, 04:50 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2017
Posts: 27
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I take it w/o Edge Filter and with Edge Filter are interchangeable ?. I plan to remove the fuel canister and clean it again. I have had it off so many times its almost like its got a zipper on it. By what I have researched the HPOP is not a problem to replace. If I swamped out the HPOP I would not know if the issue was IRP valve are the HPOP on the replacement engine. I would like to know that in-case I needed a HPOP in the future.

The HPOP pressures were a little better on the replacement engine by about 60 PSI at idle Old 584 new 640 I find it odd the HPOP just took a crap like flipping a switch as good as it ran. Most everything on the replacement engine was stuck like it came from the rust belt and I think it did. I did see what was left of the van with the engine out the chassis it did not look like it was rusty. I just figured heat from under a van body caused the corrosion. Salt/corrosion is not a issue here but its starting to be, they paint the roads white if there is any talk of snow/ice now.
post #37 of 37 Old 12-22-2017, 01:20 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Nov 2017
Posts: 27
Thanks: 4
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
IPR on 96 had a metal disk on the end I used the 95 and transferred the end off the 96 with the disk to the 95 IPR. I took it apart that was the only difference I seen with the two. It fired up pressures looked good runs good again. I think the 96 IPR was stuck and just needed cleaning the solenoid works. I did not ohm out the 95 the 96 ohms out at 6 ohms...
[email protected] likes this.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome