97 7.3 torque converter/shift issues - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 11-14-2019, 06:13 PM Thread Starter
Powerstroke.org Rookie
 
KyleCook's Avatar
 
Join Date: Nov 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
97 7.3 torque converter/shift issues

Hey, my truck is driving like the torque converter is locked up. If I let off the accelerator pedal it decels quick like a standard. It is shifting super hard. Does it sound like wiring?
KyleCook is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 11-14-2019, 06:21 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,776
Thanks: 0
Thanked 166 Times in 160 Posts
Mentioned: 6 Post(s)
Quoted: 81 Post(s)
Feedback Score: 0 reviews
Is the OD light on the shifter flashing? If so, you'll need to retrieve the diagnostic trouble codes that have been set. Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #3 of 10 Old 11-15-2019, 07:25 AM
Compression Ignition Addict
 
Join Date: Mar 2011
Location: Tx
Posts: 3,730
Thanks: 6
Thanked 283 Times in 281 Posts
Mentioned: 12 Post(s)
Quoted: 307 Post(s)
Feedback Score: 0 reviews
Get a scanner hooked up and read MAP, BPS, and EBP pressure readings. All should be reading nearly the same.

BPS sensor can cause harsh shifts and bad loping during decel etc..

Also make sure all of your tail lights are working and all fuses are good.
White95f250 is offline  
Sponsored Links
Advertisement
 
post #4 of 10 Old 11-15-2019, 09:23 AM Thread Starter
Powerstroke.org Rookie
 
KyleCook's Avatar
 
Join Date: Nov 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
Hey, I hooked up forscan and am getting no codes. I'm assuming I am supposed to check all those while the truck is running?
KyleCook is offline  
post #5 of 10 Old 11-15-2019, 09:24 AM Thread Starter
Powerstroke.org Rookie
 
KyleCook's Avatar
 
Join Date: Nov 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
I recently cleaned my ebp tube and sensor but was having issues before. It wasn't very dirty. I have noticed that the ebpv comes on quite strong when cold.
KyleCook is offline  
post #6 of 10 Old 11-15-2019, 09:29 AM Thread Starter
Powerstroke.org Rookie
 
KyleCook's Avatar
 
Join Date: Nov 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
Also, the o/d light is not flashing and if I press it it will light up.
KyleCook is offline  
post #7 of 10 Old 11-15-2019, 10:36 AM Thread Starter
Powerstroke.org Rookie
 
KyleCook's Avatar
 
Join Date: Nov 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
Those are my codes I got. The code reader doesn't seem to want to pull them. Forscan won't pull any codes.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20191115-123904_1573843154609.png
Views:	7
Size:	341.1 KB
ID:	725247  
KyleCook is offline  
post #8 of 10 Old 11-15-2019, 05:35 PM
Compression Ignition Addict
 
Patrick Feeley's Avatar
 
Join Date: Oct 2011
Location: Tehachapi, CA
Posts: 2,776
Thanks: 0
Thanked 166 Times in 160 Posts
Mentioned: 6 Post(s)
Quoted: 81 Post(s)
Feedback Score: 0 reviews
Check the codes with the key in RUN. Is there oil in the ICP connection? Cheers!

1997 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, External Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD - 1994 F350 CC DRW 2WD PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, DPPI DP, Bilsteins, $12 AIC, Coolant Filter, Explorer Overhead Console, A-Pillar w/ISSPRO Black Ice, EV Boost, and EV Pyro, Modified Pedestal, Gutted EBPV.
Patrick Feeley is offline  
post #9 of 10 Old 11-16-2019, 10:51 AM Thread Starter
Powerstroke.org Rookie
 
KyleCook's Avatar
 
Join Date: Nov 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
I've tried to pull the codes with the engine running and it shuts it off. I only ever try and pull the codes with the key on.
KyleCook is offline  
post #10 of 10 Old 11-16-2019, 10:52 AM Thread Starter
Powerstroke.org Rookie
 
KyleCook's Avatar
 
Join Date: Nov 2013
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Garage
Feedback Score: 0 reviews
I replaced the ICP sensor with a cheap Amazon one and I have it unplugged right now. The old one leaked oil through and into the wiring. I put a new wiring harness on it. I have it unplugged as I was having a starting issue and was seeing if that was it.
KyleCook is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome