Glow Plug Clicking - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 Old 02-01-2009, 05:49 AM Thread Starter
Compression Ignition Addict
 
97-Stroker's Avatar
 
Join Date: Jun 2008
Location: Mason OHIO
Posts: 383
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Glow Plug Clicking

We have a 1990 F350 7.3L dump truck up at our work. Its got the banks turbo kit on it that was installed when we bought it. Othere then that i think its all stock. My question is about the clicking i hear when i turn the key. When its been sitting over night plugged in or for a long time during the day plugged in and i turn the key the wait to start light comes on for 2 seconds and goes off. But i still hear a clicking noise. It clicks for about a min and then stops and if i turn it off and turn it back on it will do it all over again. Are these the glow plugs? and even if i run it through 3 or 4 times it still takes a long time to start. Have to use ether if we have to get out and start plowing because we dont have time to wait on it. So my question is...whats the clicking and is it suppose to do that? cause i think its the glow plugs turning off and on. Shouldnt they stay on not click on and off like that?

Thanks
-Steve
97-Stroker is offline  
Sponsored Links
Advertisement
 
post #2 of 15 Old 02-01-2009, 05:53 AM
Viking Heavy Diesel

 
Ryan Rønning's Avatar
 
Join Date: Nov 2007
Location: Wasilla, AK
Posts: 20,740
Thanks: 10
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Feedback Score: 1 reviews
How long are the intervals of the clicks.

Project Frankenstein



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
1997 Ford F-350, Dually conversion, Cobra 29 LX CB, 12000 watt converter, All LED lights, PHP Hydra, 4" DP, Napa Intake, coolant filter, 140cc AD Injectors and lots of running lights.

Quote:
Originally Posted by XPLOSIV View Post
Thanks. I'll give er a good wackin in the morning.
Ryan Rønning is offline  
post #3 of 15 Old 02-01-2009, 05:54 AM Thread Starter
Compression Ignition Addict
 
97-Stroker's Avatar
 
Join Date: Jun 2008
Location: Mason OHIO
Posts: 383
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
about 2 seconds in between each one.
97-Stroker is offline  
Sponsored Links
Advertisement
 
post #4 of 15 Old 02-02-2009, 06:31 AM
Member
 
Join Date: Dec 2008
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like you need new glow plugs. The clicking noise on my '93 is the controller for the plugs. Buy Beru (Motorcraft) glow plugs if you replace them. They are about $11 each at the parts store near me, or ebay sometimes has a deal on 'em. Just make sure you get the right ones.
PRESTROKER is offline  
post #5 of 15 Old 02-03-2009, 06:42 AM
Compression Ignition Addict
 
baddkarmaracing's Avatar
 
Join Date: Jul 2008
Location: harlingen tx
Posts: 1,144
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Red face

my 94 clicks too but i dotn have problems with it being hard to start... it will start and then die sometimes though
baddkarmaracing is offline  
post #6 of 15 Old 02-03-2009, 07:08 AM
Member
 
Join Date: Dec 2008
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I checked my truck yesterday, no starting problems though.. It clicks (the controller) but I think this is normal, my truck has always done it. Have your GP's ever been changed?
PRESTROKER is offline  
post #7 of 15 Old 02-03-2009, 07:13 AM
Emergency Services
 
cchase's Avatar
 
Join Date: May 2007
Location: Columbus, OH
Posts: 5,534
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to cchase
I had a new GPR go bad on me, and it clicked just like you are describing. it also melted shortly after


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


On vacation from a truck for a year or...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Looking at 6.4s Moving in a few months then hopefully buying my dream truck!!!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Driving an Audi till then...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

but at work I drive
16 E-450s 7.3 powerstroke Ambulances
7 Duramaxes
1 GMC Kodiak Ambulance

NO CUMMINS.....
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cchase is offline  
post #8 of 15 Old 02-03-2009, 09:43 AM Thread Starter
Compression Ignition Addict
 
97-Stroker's Avatar
 
Join Date: Jun 2008
Location: Mason OHIO
Posts: 383
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Im thinking the glow plug relay is bad. If i watch the batter metter while its going through the cycle it goes really low when it clicks then back to the spot it was in before the click. Everytime it clicks it pulls from the battery....does this make sense? Im thinking its the relay. The plugs were replaced last year...

-Steve
97-Stroker is offline  
post #9 of 15 Old 02-03-2009, 10:38 AM
Member
 
Join Date: Dec 2008
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
IT BEING A '90 model, is the relay on the fender? If so I would turn the key on, hop out and see if that's what you hear. The later models (mine is a 93), the relay is right behind the air filter housing.
PRESTROKER is offline  
post #10 of 15 Old 02-04-2009, 06:14 AM Thread Starter
Compression Ignition Addict
 
97-Stroker's Avatar
 
Join Date: Jun 2008
Location: Mason OHIO
Posts: 383
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
its a 90 and the relay is right behind the fuel filter...witch i think has been relocated since it has the banks turbo kit. i can get some pics of its location.
97-Stroker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome