no starting with glow all glow plugs on - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 03-09-2019, 06:37 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Mar 2019
Posts: 3
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
no starting with glow all glow plugs on

I have a 1989 7.3 bucket International bucket truck with 55000 miles that won't start without a squirt of starter fluid. All glow plugs glow on start up. I suspect there is so much carbon in the pre-chambers the fuel won't ignite.
I was thinking to remove injectors and glow plugs and use a wire brush with cleaning solvent to clean inside glow pug holes then blow compressed air through injector holes and let the loose deposits
go through the glow plug holes. Does any one have a better idea other then removing heads?
jamo1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Glow plugs not coming on Christian0379 94-98 7.3L General Powerstroke Discussion 5 09-12-2018 06:27 PM
New glow plugs and PO672 code comes back 760GONZO 6.0 Motor problems 1 06-05-2017 01:00 PM
95 Power Stroke with no glow plugs? 95ps_wo 94-98 7.3 Motor Problems 1 11-06-2005 05:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome