1994 F250 7.3 No Turbo - Page 2 - Ford Powerstroke Diesel Forum
7.3L IDI (Non-Powerstroke) Diesels Technical discussion of topics related to vehicles powered by the 7.3 Liter In-Direct Injection Navistar engines.

 2Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 13 Old 02-26-2017, 01:23 AM Thread Starter
Compression Ignition Addict
 
doubleslottedflaps's Avatar
 
Join Date: Mar 2007
Posts: 845
Thanks: 2
Thanked 34 Times in 31 Posts
Mentioned: 5 Post(s)
Quoted: 163 Post(s)
Feedback Score: 0 reviews
I picked up the 94 and it is a turbo powerstroke. It has a metal thing over the top of the fuel filter that says "direct injection power stroke diesel". I drove it from mississippi to los angeles and just got in this evening. 92,000 miles. The tank switching does not work and its stuck on the rear tank. I had to replace the crank sensor in mississippi.
doubleslottedflaps is offline  
Sponsored Links
Advertisement
 
post #12 of 13 Old 02-28-2017, 09:03 PM
Compression Ignition Addict
 
Join Date: Aug 2008
Location: Madison, WI
Posts: 4,285
Thanks: 4
Thanked 157 Times in 153 Posts
Mentioned: 10 Post(s)
Quoted: 134 Post(s)
Feedback Score: 0 reviews
Sounds like a nice acquisition. At 92,000, it's not even broken in. But it being an automatic, most likely it's a '95. What's the 10th digit of the VIN?

The selector valve is on the inside of the frame, driver's side, pretty-much below the driver's seat. See if you hear it make any noise when you turn the key on and flip the switch. That'll be the first thing to know. If you want to troubleshoot it further, this might help - http://userpages.chorus.net/elephant...nkSelector.pdf .

It was actually the cam position sensor you replaced (truck doesn't have a crank sensor). Was it a Ford or IH sensor? Aftermarket brands are known not to work well in our trucks. Might be worth getting another one and stashing it in the glove box.
madpogue is offline  
post #13 of 13 Old 04-16-2018, 07:26 PM
Powerstroke.org Rookie
 
Join Date: Apr 2018
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
E40D pretty bad

Quote:
Originally Posted by h0trod View Post
from what I hear the E4OD is temperamental in the IDI's
a ZF5 was my choice.
Have the E40D in my 93 7.3 idi non-turbo its got 217000 miles and have had 2 transmissions put in it. First one was rebuild second one was whole different tranny. I would rather have the ZF5 but don't think its worth doing now.
1993FordDiesel is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome