Anyone who has had an EGT sensor fail, please read - Page 3 - Ford Powerstroke Diesel Forum
6.7 Problems Forum (2011-2016) 6.7 Problems Forum

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #21 of 25 Old 02-20-2015, 12:17 PM
Compression Ignition Addict
 
Join Date: Mar 2014
Posts: 279
Thanks: 19
Thanked 41 Times in 31 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Blwnsmoke:

Thanks for posting on this issue for our trucks Sir!

FWIW,....I have never had this happen with my 2014, but one of my friends that had a 2012 Ford 6.7 Super Duty 6.7 had it happen to him and it DID leave him on the side of the road having to call a wrecker and tow his truck to the Ford Dealer. As a result of his experience, I went to my Ford Dealer and bought one of those sensors to have as a "spare" JUST IN CASE it happens to my truck.

My Ford Tech said there are like FOUR of those sensors in the exhaust system but the one most prone to failure called "BANK ONE, SENSOR FOUR" which is the one behind the DPF as stated in the "Bloomberg" article by blwnsmoke.
I paid about sixty ($60.00) for that sensor but hopefully I won't have to
use and if I do hopefully the new one will work!
John_P is offline  
Sponsored Links
Advertisement
 
post #22 of 25 Old 03-13-2015, 06:07 PM
Powerstroke.org Rookie
 
Join Date: Jan 2015
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I just took my 13 in for this flash and immediately after leaving the dealer I got a CEL with code P220a. NOx sensor needs changed. Truck ran like a dream before the flash now it's been a week and it's still in the shop.
StrokeDeez is offline  
post #23 of 25 Old 05-20-2015, 07:38 PM
Public Enemy #1
 
Derwood's Avatar
 
Join Date: Mar 2015
Posts: 133
Thanks: 1
Thanked 7 Times in 7 Posts
Mentioned: 1 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
I'm sorry I don't trust Ford at all with this. My 2011 shut down in a very bad neighborhood, luckily during the day. This re-flash is sketchy and I am now in control of my truck, Ford will not be dictating when my truck shuts down to comply with some random nazi epa edict. I personally hope a huge f....ing lawsuit opens this crap wide open. Why in the hell do we need so many egt sensors? We all know why and it is crap.....just my .02 cents /end rant.
Derwood is offline  
Sponsored Links
Advertisement
 
post #24 of 25 Old 10-06-2015, 02:12 PM
Powerstroke.org Fanatic
 
Join Date: Dec 2014
Posts: 105
Thanks: 3
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Amen! Me too sir!!!
Frederick67psd is offline  
post #25 of 25 Old 04-01-2016, 05:32 PM
Powerstroke.org Fanatic
 
TaxmanHog's Avatar
 
Join Date: Mar 2016
Posts: 121
Thanks: 2
Thanked 2 Times in 2 Posts
Mentioned: 2 Post(s)
Quoted: 44 Post(s)
Garage
Feedback Score: 0 reviews
Already had the above flash previously, but ran my VHR this afternoon, to check my oil life monitor rating, also had this notification in the email report

Quote:
Field Service Actions
Notice # Description
15M02 EXHAUST GAS TEMPERATURE SENSOR EXTENDED COVERAGE
Wondering if this should be changed out now, the engine has been experiencing an occasionally idle hiccup.

Seems I have not seen it warning that the clean cycle is starting in a while, wondering if this sensor is having a problem, though I don't have any codes
TaxmanHog is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome