Another Failed 6.7l HPFP - Ford Powerstroke Diesel Forum
6.7 Problems Forum (2011-2016) 6.7 Problems Forum

 1Likes
  • 1 Post By HeavyAssault
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 09-15-2019, 07:50 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Another Failed 6.7l HPFP

2014 f250 80k miles. Truck was running fine. No water in fuel, no error lights. Turned off truck to use rest area, came out and truck wouldn’t start. Towed 75 miles to closest dealership. The ran a “pinpoint test” and said it was probably a pump but that they were going to first replace the fuel rail and pressure regulator. They received approval for the repairs. When tearing down parts they located metal shavings. They have now denied the claim under the factory warranty. I am hoping extended warranty covers but after reading all the articles online I am sickened. Service writer said no evidence of water or def in fuel “but we haven’t tested for gasoline yet...”

Dealer wants over $10k to repair. Problem... I don’t have $10,000. How can they approve the repairs to the regulator and fuel rail but then deny the hpfp? The service writer said the HPFP isn’t covered. Help!!!
AnotherDeadPowerstroke is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 09-16-2019, 05:06 AM
N.S.D.Q.


 
HeavyAssault's Avatar
 
Join Date: Oct 2007
Location: Middle VA
Posts: 8,133
Thanks: 59
Thanked 394 Times in 379 Posts
Mentioned: 94 Post(s)
Quoted: 819 Post(s)
Feedback Score: 3 reviews
Sounds like you need to read your warranty coverage. Metal shavings is not a warranty void situation especially at 80k.
lowmpg likes this.



Officially The Biggest Midget In The Game

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HeavyAssault is offline  
post #3 of 5 Old 09-16-2019, 01:02 PM
Premium Member
 
lowmpg's Avatar
 
Join Date: Mar 2014
Location: The Island
Posts: 711
Thanks: 17
Thanked 45 Times in 45 Posts
Mentioned: 4 Post(s)
Quoted: 107 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by HeavyAssault View Post
Sounds like you need to read your warranty coverage. Metal shavings is not a warranty void situation especially at 80k.
Agreed, that situation blows...bad, but certainly isn't something Ford should cover at that many miles.

The Resurrection
lowmpg is online now  
Sponsored Links
Advertisement
 
post #4 of 5 Old 09-16-2019, 01:41 PM
Compression Ignition Addict
 
Join Date: Jan 2012
Posts: 380
Thanks: 10
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Feedback Score: 0 reviews
What were the symptoms? Would it just not start? Did it make any funny noises or anything?
Bluwaterbrew84 is offline  
post #5 of 5 Old 09-21-2019, 03:48 AM
Compression Ignition Addict
 
Jstahley's Avatar
 
Join Date: Sep 2017
Posts: 255
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 1 Post(s)
Quoted: 31 Post(s)
Feedback Score: 0 reviews
Im going thru a pump starting to fail. 1st i would get a contribution code that would pop up ever once in a wile. Like every few weeks.( i drive 1k a week for work some weeks) then got more regular and would jump around from cylinders. I over treat with howes and power service dont know if it helped or not. I changed filters and there was metal shavings in the frame filter.
Jstahley is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome