Ford Powerstroke Diesel Forum

Ford Powerstroke Diesel Forum (https://www.powerstroke.org/forum/)
-   6.7 Problems Forum (2011-2016) (https://www.powerstroke.org/forum/6-7-problems-forum-2011-2016/)
-   -   High A/C Head Pressure - Fan Clutch or blockage? (https://www.powerstroke.org/forum/6-7-problems-forum-2011-2016/1364969-high-c-head-pressure-fan-clutch-blockage.html)

cmunsell 06-19-2019 05:29 AM

High A/C Head Pressure - Fan Clutch or blockage?
 
Had a bad evaporator replaced a few months ago, now I am getting warm air at idle (blows cold when moving). This leads me to believe that I am not getting enough air over the condenser at idle fan speed.

What has me curious is the high head pressure at idle - low side is ~45 lbs which seems fine, but the high side was touching 450 which is crazy. I have not had a second set of hands to monitor the high side pressure if I rev the RPMs a bit to move the fan faster.

My question - can weak air flow over the condenser cause the pressure to get this high?

My other thought is the dryer element - they did not replace that when they did the evap replacement. Could that be gummed up enough to restrict freon through the condenser causing the high pressure?

Summer in Houston is going to be a little tough if I cannot get this figured out.

Other considerations - my truck went on a diet and I unplugged everything from the EGR cooler, is there some kind of sensor connected to that harness that could limit fan speed? Engine is not experiencing any overheating at all.

Old King Coal 06-20-2019 05:31 PM

The delete didn't have anything to do with it. I'd put my money on the fan clutch. A shop with IDS can command the clutch to lock up, if it doesn't then you'll know. The reason I say that is the cold air while driving. If it was plugged, it wounldn't matter if you were driving or not, because the refrigerant wouldn't have anywhere to go.

cmunsell 06-21-2019 06:19 AM

Thanks for the reply - I was leaning that direction as well but am now second guessing. I monitored the 'Fan Speed Desired' vs. ' Vistronic Cooling Fan Speed Sensor' PIDs and it appears as though the fan is turning at or near the desired speed.

For instance, this morning (while still relatively cool outside, ambient temp 83*) upon startup desired fan speed was 875 RPM and fan speed sensor was showing 82.5 (I assume the PID shows a 1/10 scale for some reason). The AC was also blowing cold at this time. High side pressure was still getting up to ~340 which still feels high.

I will test again this afternoon when it is much warmer out to check the result. I am starting to think either I have air in the system or perhaps an overcharge as after I shut down after a moderate drive up to operating temps, static pressure in the system was reading 150.

Will try again this afternoon and keep the thread posted. Hopefully documenting the findings will help someone else out - lord knows weak AC in the summer is not the most fun.

Grish76 06-21-2019 05:59 PM

I'd start with replacing the pressure switch and then proceed to the expansion valve.

Of course this is only if you are certain you are good on freon level.

Old King Coal 06-21-2019 06:18 PM

High A/C Head Pressure - Fan Clutch or blockage?
 
Iím no help with PIDs but yeah, that high side is about 90#s over on the chart I looked at. They really shouldíve changed the dryer. And probably the orifice tube as well. Idk. Iím no a/c expert but I always thought you replaced those two whenever you opened the system to atmosphere.

I does seem like you have a restriction. Good luck and let us know what you find.


All times are GMT -8. The time now is 03:12 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vB.Sponsors
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

 
For the best viewing experience please update your browser to Google Chrome