TYRANT DIESEL tunes, anyone having surging? - Ford Powerstroke Diesel Forum
6.7 Performance Parts Discussion (2011-2016) 6.7 Performance Parts Discussion

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 04-29-2018, 07:16 AM Thread Starter
Powerstroke.org Fanatic
 
BryanDowdy's Avatar
 
Join Date: Jul 2009
Location: Montrose, CO
Posts: 97
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
TYRANT DIESEL tunes, anyone having surging?

I have a '13 deleted and have tried PIP and PSE tunes, Tow and no power DPF off only. All the tunes cause a surge of 1st gear when taking off. After searching, I've read that Tyrant tunes fix the surge issue. Before I purchase a tune for the third time, I'd like the hear feedback specifically that their tunes do not cause a surge.
BryanDowdy is offline  
Sponsored Links
Advertisement
 
post #2 of 12 Old 04-29-2018, 07:23 AM
Compression Ignition Addict
 
DiggerDerrik's Avatar
 
Join Date: Mar 2017
Posts: 287
Thanks: 0
Thanked 33 Times in 33 Posts
Mentioned: 5 Post(s)
Quoted: 65 Post(s)
Feedback Score: 0 reviews
I have a single Tyrant tow tune on my SCT GTX 2011 F350. I’ve not ever had a surge. However it did force the transmission to have to relearn and it shifted very hard for the first few hundred miles.
DiggerDerrik is offline  
post #3 of 12 Old 04-29-2018, 07:43 AM
Compression Ignition Addict
 
Join Date: Aug 2012
Posts: 799
Thanks: 5
Thanked 64 Times in 64 Posts
Mentioned: 8 Post(s)
Quoted: 209 Post(s)
Feedback Score: 0 reviews
What exactly is a "surge of first gear"
SOOTIE is offline  
Sponsored Links
Advertisement
 
post #4 of 12 Old 04-29-2018, 07:45 AM Thread Starter
Powerstroke.org Fanatic
 
BryanDowdy's Avatar
 
Join Date: Jul 2009
Location: Montrose, CO
Posts: 97
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
When I take off slowly or am trying to go slow in say a parking lot, the it takes off slowly then has a surge of power/speed.
BryanDowdy is offline  
post #5 of 12 Old 04-29-2018, 11:58 AM
Compression Ignition Addict
 
Join Date: Aug 2012
Posts: 799
Thanks: 5
Thanked 64 Times in 64 Posts
Mentioned: 8 Post(s)
Quoted: 209 Post(s)
Feedback Score: 0 reviews
So just tell your tuner that and have them tweak the tune. Why keep spending money on different tuners when you buy "custom tunes" to get them"custom" to your liking.
SOOTIE is offline  
post #6 of 12 Old 04-30-2018, 09:21 AM Thread Starter
Powerstroke.org Fanatic
 
BryanDowdy's Avatar
 
Join Date: Jul 2009
Location: Montrose, CO
Posts: 97
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by SOOTIE View Post
So just tell your tuner that and have them tweak the tune. Why keep spending money on different tuners when you buy "custom tunes" to get them"custom" to your liking.
Back when I bought the tune I did mention it to the tuner and tried a few revised tunes. None of them helped the issue and that was over a year ago.
BryanDowdy is offline  
post #7 of 12 Old 04-30-2018, 11:05 AM
Compression Ignition Addict
 
joebuck's Avatar
 
Join Date: May 2014
Location: Graham,WA
Posts: 1,195
Thanks: 44
Thanked 104 Times in 101 Posts
Mentioned: 9 Post(s)
Quoted: 142 Post(s)
Feedback Score: 1 reviews
I run Tyrant tunes and no surging at all
joebuck is offline  
post #8 of 12 Old 05-01-2018, 06:45 AM
Drunk Post Extraordinair
 
Old King Coal's Avatar
 
Join Date: Mar 2017
Location: Alabama
Posts: 845
Thanks: 7
Thanked 100 Times in 92 Posts
Mentioned: 5 Post(s)
Quoted: 203 Post(s)
Garage
Feedback Score: 1 reviews
Mine does it too. Didn't know it was a problem. I always assumed it was because it was a tow tune. Figured it was set up to get a heavy load rolling. It doesn't do it every time, just under light throttle. I've never loaded any of my other tunes to see if they do it.

Either way, it doesn't bother me.

Free men must live simple lives and have simple pleasures.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Old King Coal is offline  
post #9 of 12 Old 05-03-2018, 11:16 AM Thread Starter
Powerstroke.org Fanatic
 
BryanDowdy's Avatar
 
Join Date: Jul 2009
Location: Montrose, CO
Posts: 97
Thanks: 2
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Talk to the original tune guy and checked things and he says it has to be truck issue. Because my no power tune only turns off emissions. The truck runs fine when it's not deleted, so I dont know.
BryanDowdy is offline  
post #10 of 12 Old 05-05-2018, 06:42 AM
Premium Member
 
Builtfordtough1776's Avatar
 
Join Date: Apr 2016
Location: Augusta
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 7 Post(s)
Garage
Feedback Score: 0 reviews
I also have Tyrant tunes, but i havent had any surging. But i used to own a 99' f250 with the 7.3 and it had a surging issue that ended up just being a faulty TPS (throttle position sensor) and after a cheap 20 dollar fix it didnt surge. Not saying thats the issue youre having but maybe the tunes are a little jacked up and arent reading the data from the sensor in 1st gear properly.
Builtfordtough1776 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome