Stock EGT sensor for EGR Delete - Page 2 - Ford Powerstroke Diesel Forum
6.7 Performance Parts Discussion (2011-2016) 6.7 Performance Parts Discussion

 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #11 of 21 Old 01-30-2018, 11:32 AM
Compression Ignition Addict
 
Hayhook's Avatar
 
Join Date: May 2012
Location: Vancouver, WA
Posts: 196
Thanks: 7
Thanked 10 Times in 10 Posts
Mentioned: 2 Post(s)
Quoted: 57 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by andrewtac View Post

PID: 22055E
MIN 0
MAX 2000
scale x1
Unit C
(0.0004*(((1164.26*(((256*A)+B)*0.00097285))/(4.98-(((256*A)+B)*0.00097285)))*((1164.26*(((256*A)+B)* 0.00097285))/(4.98-(((256*A)+B)*0.00097285)))))+(1.107*((1164.26*(((2 56*A)+B)*0.00097285))/(4.98-(((256*A)+B)*0.00097285))))-237.33 "
So, it says "Unit C" which is Celsius, right? does the reading come across in Fahrenheit or Celsius?
Hayhook is offline  
Sponsored Links
Advertisement
 
post #12 of 21 Old 01-30-2018, 01:28 PM
Powerstroke.org Fanatic
 
Join Date: Dec 2016
Posts: 97
Thanks: 2
Thanked 4 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 31 Post(s)
Feedback Score: 0 reviews
I believe it is degrees F. The temps are in line with previous temps from pre delete.
andrewtac is offline  
post #13 of 21 Old 02-02-2018, 10:09 AM
Powerstroke.org Fanatic
 
Join Date: Sep 2014
Posts: 99
Thanks: 2
Thanked 6 Times in 6 Posts
Mentioned: 1 Post(s)
Quoted: 30 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by andrewtac View Post
I cannot take credit for the below; given to me by another user on another forum. Use one of the 4 EGT probes from the exhaust in the EGR block off plate and plug into the EGRT11 harness plug that was on the probe in the EGR before removal. I was confused and rerouted my EGT lines from the the exhaust all the way back up to the block off plate; this was a major pain and did not work. Using the EGR temp sensor harness, and a EGT probe from the exhaust, and the formula below worked. It was also super simple as the EGR temp sensor harness is right by the EGR block off plate (which should have a hole for an EGT probe).

"I used EGRT11 which is real handy to the block off plate.

I then came up with a custom equation for Torque Pro to convert the volts read by the sensor to temperature. I haven't been able to compare the output of Torque to a known calibrated sensor but it does seem to be in the right ballpark.

PID: 22055E
MIN 0
MAX 2000
scale x1
Unit C
(0.0004*(((1164.26*(((256*A)+B)*0.00097285))/(4.98-(((256*A)+B)*0.00097285)))*((1164.26*(((256*A)+B)* 0.00097285))/(4.98-(((256*A)+B)*0.00097285)))))+(1.107*((1164.26*(((2 56*A)+B)*0.00097285))/(4.98-(((256*A)+B)*0.00097285))))-237.33 "
Andrew,
Just downloaded Torque Pro. Under settings>Manage extra PIDS/SENSORS>add custom PID, then under Equation, do I input exactly what you have with all the numbers and symbols?
When I do it it, comes up with an error mismatched parentheses.
rcg270 is offline  
Sponsored Links
Advertisement
 
post #14 of 21 Old 02-02-2018, 10:10 AM
Powerstroke.org Fanatic
 
Join Date: Dec 2016
Posts: 97
Thanks: 2
Thanked 4 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 31 Post(s)
Feedback Score: 0 reviews
Check the parentheses
andrewtac is offline  
post #15 of 21 Old 02-02-2018, 01:18 PM
Compression Ignition Addict
 
Hayhook's Avatar
 
Join Date: May 2012
Location: Vancouver, WA
Posts: 196
Thanks: 7
Thanked 10 Times in 10 Posts
Mentioned: 2 Post(s)
Quoted: 57 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by andrewtac View Post
I believe it is degrees F. The temps are in line with previous temps from pre delete.


To confirm, even though the input says C the readout is in Fahrenheit degrees.


Sent from my iPhone using Tapatalk
Hayhook is offline  
post #16 of 21 Old 12-28-2018, 06:34 AM
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Hoping to resurrect this thread. I'm trying to read the temp sensor at the manifold pre turbo.

When I add the Custom equation to torque pro it says 237.33 " does not exist...... any ideas?
cdorsey50stang is offline  
post #17 of 21 Old 02-11-2019, 12:32 PM
Member
 
cmunsell's Avatar
 
Join Date: Oct 2018
Location: Houston
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
I will double up on the resurrection hopes.

My truck is a 2013 on a diet with block off plates.

I am using my iPhone so unable to have Torque Pro. Anyone know if OBD Fusion will get me the same result?

I have downloaded that app and there is a Ford specific PID that says Exhaust Gas Recirculation Temperature Sensor C (Bank 1, Sensor 2)

I have also tried to enter the manual formula above and keep getting a 'No Data Received' message.

Anyone have any experience with this app? Do I need to swap out the temp sensor that was in the EGR pipe with one from the DPF in order to get a reading? Right now I am using the probe that was in the EGR crossover pipe.

Would love to be able to figure this out to avoid buying a separate probe/monitor.
cmunsell is offline  
post #18 of 21 Old 02-11-2019, 03:51 PM
Premium Member

 
G8orFord's Avatar
 
Join Date: Jan 2014
Location: Northwest, FL
Posts: 9,055
Thanks: 304
Thanked 1,048 Times in 977 Posts
Mentioned: 198 Post(s)
Quoted: 2518 Post(s)
Garage
Feedback Score: 1 reviews
The one you're looking for is EGRTA not EGRTC. I'm not sure if the 2013 has EGRTC or not, but I'm pretty sure the one you're referencing is "A". You may want to try Forscan, I'm pretty sure they have an iOS version. It's a bit of a different animal compared to TP or OBD Fusion, but about as complete as you can get.

Dexter
2017 F-250 Lariat CCSB FX4 SRW- A few Forscan tweaks
My old Truck, now son's truck:
2004 F-250SD Lariat CCSB FX4 SRW; SCT X4 w/custom tunes (currently
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
SPD)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
FICM;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
FICM Tuner (currently Atlas40);
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Stage 1.5 Turbo;

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Stage 1 HPOP;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
VK688 Oil Cooler Relocate with coolant re-route;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Water Pump;

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
O-ringed Heads; ARP Studs; Fel-Pro Gaskets;
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Coolant Filter;
DashCommand on PLX Kiwi2 + iMFD with EGT & Fuel/Oil Pressure

Last edited by G8orFord; 02-11-2019 at 04:06 PM.
G8orFord is offline  
post #19 of 21 Old 02-12-2019, 05:04 AM
Powerstroke.org Rookie
 
Join Date: Apr 2013
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
I got Torque pro to work on reading that sensor. Its the one at the bottom of the pic. "EGT EGR"
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20190212-090412_Torque_1549980324658.jpg
Views:	36
Size:	1.00 MB
ID:	714623  
cdorsey50stang is offline  
post #20 of 21 Old 02-12-2019, 05:25 AM
Member
 
cmunsell's Avatar
 
Join Date: Oct 2018
Location: Houston
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
I will keep trying. I reset the app and reconnected last night, I was getting a reading from the EGRTC Sensor but it was jumping all over the place and returning values that did not make much sense to me. For instance, at idle it was showing 400-500. However when I began accelerating at a normal pace it would spike to 1,800 and then drop to 32 back and forth and in between. Did not pass the sniff test.

I am wondering if using the stock EGR probe rather than one from the DPF is throwing it off.

Will keep trying to get the formula to work but in the meantime all suggestions greatly appreciated!
cmunsell is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome