NAV going bad? - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion (2011-2016) 6.7 Electronics Discussion

 2Likes
  • 1 Post By UR2EZ
  • 1 Post By witness
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 11-29-2019, 12:27 PM Thread Starter
Premium Member
 
Join Date: Aug 2016
Posts: 186
Thanks: 11
Thanked 13 Times in 10 Posts
Mentioned: 2 Post(s)
Quoted: 77 Post(s)
Feedback Score: 0 reviews
NAV going bad?

Have a 2016 XLT Lariat blah blah blah,,, loaded.
Left Raleigh NC yesterday morning and got half \way to northeast Ohio and my Navigation went out. Wouldn't load/open, then would start to load then go back to home screen. Tried getting it going the next 4 hours to no avail. Came home today and after trying for 5 hours, it started working normal 4 hours from the house.
Also, I use bluetooth for music from my iPhone and the entire time driving there and back, it sounds like the music is hitting a skip, like a record player would do 40 years ago. Remember them some of you? Would happen every few minutes then play decent for 20-30 minutes then do it again every few minutes.

My fear is the unit is going bad. It did this shortly after I bought it new in August 2016 but then worked fine since so I thought it was old man operator error.

Now it's over 3 years old, 33,000 miles and probably out of warranty?
witness is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 11-29-2019, 01:06 PM
N.S.D.Q.


 
HeavyAssault's Avatar
 
Join Date: Oct 2007
Location: Middle VA
Posts: 8,581
Thanks: 59
Thanked 431 Times in 416 Posts
Mentioned: 101 Post(s)
Quoted: 919 Post(s)
Feedback Score: 3 reviews
Have you tried to reset the system?? For me it's hold the > (scan???) button with the power button. After a few it will start the reset/restart process. Do not try this while driving, and verify the correct buttons with your system and the owners manual.



Officially The Biggest Midget In The Game

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

HeavyAssault is offline  
post #3 of 5 Old 11-29-2019, 01:55 PM
Compression Ignition Addict
 
UR2EZ's Avatar
 
Join Date: Apr 2018
Posts: 432
Thanks: 38
Thanked 66 Times in 65 Posts
Mentioned: 15 Post(s)
Quoted: 69 Post(s)
Feedback Score: 0 reviews
Also try updating it. They have periodic updates that need to be preformed. You used to be able to do it yourself online but now you have to go to the dealer

Sent from my SM-G975U using Tapatalk
HeavyAssault likes this.
UR2EZ is offline  
Sponsored Links
Advertisement
 
post #4 of 5 Old 11-30-2019, 03:00 AM Thread Starter
Premium Member
 
Join Date: Aug 2016
Posts: 186
Thanks: 11
Thanked 13 Times in 10 Posts
Mentioned: 2 Post(s)
Quoted: 77 Post(s)
Feedback Score: 0 reviews
I haven't tried the reset, I will try that first. If it doesn't work I'll try the stealership.
HeavyAssault likes this.
witness is offline  
post #5 of 5 Old 12-01-2019, 05:18 AM
Premium Member
 
lowmpg's Avatar
 
Join Date: Mar 2014
Location: The Island
Posts: 732
Thanks: 17
Thanked 48 Times in 48 Posts
Mentioned: 4 Post(s)
Quoted: 113 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by witness View Post
I haven't tried the reset, I will try that first. If it doesn't work I'll try the stealership.
Recommend before a dealer visit, if the reset doesn't work, you pull the fuse for the system for a hard restart.
https://www.powerstroke.org/forum/ge...k-how-fix.html

The Resurrection
lowmpg is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome