2011 Steering wheel buttons/horn not working - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion (2011-2016) 6.7 Electronics Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 08-21-2019, 07:21 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2019
Posts: 16
Thanks: 7
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
2011 Steering wheel buttons/horn not working

Replaced clock spring and the buttons/horn still do not work. It's driving me crazy. I have no blown fuses.

With that said im also having issues with right rear blinker and brake light. Hoping they are related however im sure it's unlikely.

Please help

Sent from my Pixel 3 XL using Tapatalk
FiEnD is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-22-2019, 03:04 AM
Compression Ignition Addict
 
UR2EZ's Avatar
 
Join Date: Apr 2018
Posts: 320
Thanks: 30
Thanked 38 Times in 37 Posts
Mentioned: 11 Post(s)
Quoted: 48 Post(s)
Feedback Score: 0 reviews
Blinker and brake light are most likely a bulb out. Not sure about the controls and horn though. None of the controls are working on the steering wheel?

Sent from my SM-G975U using Tapatalk
UR2EZ is online now  
The Following User Says Thank You to UR2EZ For This Useful Post:
FiEnD (08-22-2019)
post #3 of 3 Old 08-22-2019, 05:25 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2019
Posts: 16
Thanks: 7
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by UR2EZ View Post
Blinker and brake light are most likely a bulb out. Not sure about the controls and horn though. None of the controls are working on the steering wheel?

Sent from my SM-G975U using Tapatalk
I have done all basic trouble shooting for all the issues I have. Replaced bulbs and checked fuses. I feel there could be a bad Module somewhere and was hoping someone has experienced this issue before because it's not your average bad bulb or fuse fix.

None of the controls in the steering wheel work. Neither does the horn when I press it. The horn does sound when I remote lock.

It's as if the steering wheel is completely disconnected and I found that 99.9% of the time it's a bad clock spring but replacing it didn't fix the issues.

Sent from my Pixel 3 XL using Tapatalk
FiEnD is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome