Instrument Cluster Issue - Ford Powerstroke Diesel Forum
6.7 Electronics Discussion (2011-2016) 6.7 Electronics Discussion

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-13-2019, 11:08 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jun 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Instrument Cluster Issue

Hello all....

My name is Mark and I have a 2016 F350 Lariet. The instrument cluster has been shutting down. It will come back up upon restart but the dealer has no ideas and I don't want to start and pay for a fishing expedition. Has anyone had a problem like this and if so what was the diagnosis and fix?
Markmm64 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 06-15-2019, 07:09 PM
Drunk Post Extraordinair
 
Old King Coal's Avatar
 
Join Date: Mar 2017
Location: Alabama
Posts: 867
Thanks: 7
Thanked 103 Times in 95 Posts
Mentioned: 5 Post(s)
Quoted: 214 Post(s)
Garage
Feedback Score: 1 reviews
You problem sounds similar to this guys.

Check this thread, maybe it will help.

So strong is Tradition that later generations will dream of what they have never seen.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Old King Coal is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome